bugThe FreeType Project - Bugs: bug #19873, Legendum font wrongly displayed...

 
 

bug #19873: Legendum font wrongly displayed when faking bold with FT-2.3.4 (using autohinter)

Submitted by:  Pablo Rodríguez <ousia>
Submitted on:  Mon May 14 21:32:58 2007  
 
Severity: 3 - NormalItem Group: None
Status: Wont FixPrivacy: Public
Assigned to: Werner LEMBERG <wl>Open/Closed: Closed
Planned Release: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue Nov 1 03:12:44 2016, comment #5:

The FreeType emboldener is sensitive to errors in contour orientations, i.e., the wrong orientation would inverse the direction of emboldening, making some parts thinner. There is no way to diagnose the orientation errors in FreeType currently.

In fact, you can consider these emboldening artifacts as a diagnostic of the problem fonts. :) This is a feature, rather than bug.

Alexei Podtelezhnikov <podtelez>
Project Member
Fri Mar 20 12:47:58 2009, comment #4:

The correct solution is probably to first embolden the glyphs,
then autohinting the character.

I mention this here explicitly so that it won't get forgotten.

Werner LEMBERG <wl>
Project AdministratorIn charge of this item.
Mon Apr 21 23:06:16 2008, comment #3:

The problem occurs for all hinting settings,
no matter whether the byte code interpreter is used or the
autohinter and even turning off hinting completely
doesn’t help.

Mike FABIAN <mfabian>
Mon Apr 21 23:02:33 2008, comment #2:

The problem when emboldening the gulim.ttc font can
be easily seen with the command:

xfd -start 63744 -fa "Gulim:weight=200:pixelsize=27"

(Same problem with the other three faces in gulim.ttc,
i.e. “Dotum”, “GulimChe”, and “DotumChe”).

A screenshot is available here:

https://bugzilla.novell.com/attachment.cgi?id=209402

Mike FABIAN <mfabian>
Mon Apr 21 22:52:31 2008, comment #1:

The same problem is seen with FT-2.3.5 and the
Korean font gulim.ttc (from Windows Vista).

For details see

http://bugzilla.novell.com/show_bug.cgi?id=381779

Mike FABIAN <mfabian>
Mon May 14 21:32:58 2007, original submission:

As shown in the attachment below, FT-2.3.4 seems to have problems to fake bold characters in Legedum's lowercase and uppercase acute accented letters. Just in case it helps, FT uses autohinter.

This happens in both the upright and slanted fonts (also attached).

Thanks for your excellent work,

Pablo

PS: this was previously reported in bug 18875, but since the issue is different, I think it would be better to close bug 18875 (since it has been fixed).

Pablo Rodríguez <ousia>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #12768:  wronglegndmbold.png added by ousia (43kB - image/png)
file #12769:  legendum.tar.bz2 added by ousia (61kB - application/x-bzip)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by podtelez (Posted a comment)
  • -unavailable- added by wl (Posted a comment)
  • -unavailable- added by mfabian (Posted a comment)
  • -unavailable- added by ousia (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue Nov 1 03:12:44 2016podtelezStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
    Fri Mar 20 12:47:58 2009wlAssigned toNone=>wl
      SummaryLegendum font wrong displayed when faking bold with FT-2.3.4 (using autohinter)=>Legendum font wrongly displayed when faking bold with FT-2.3.4 (using autohinter)
    Mon May 14 21:32:58 2007ousiaAttached File-=>Added wronglegndmbold.png, #12768
      Attached File-=>Added legendum.tar.bz2, #12769

    Back to the top


    Powered by Savane 3.1-cleanup