bugAVR C Runtime Library - Bugs: bug #22539, GCC can't find AVR35 object files

 
 

bug #22539: GCC can't find AVR35 object files

Submitted by:  Brad Schick <schickb>
Submitted on:  Mon 10 Mar 2008 07:47:29 PM UTC  
 
Category:  Build Infrastructure Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build system
Status:  Works For Me Assigned to:  Eric Weddington <arcanum>
Percent Complete:  0% Open/Closed:  Closed
Release:  1.6.1 Fixed Release:  None

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 22 Feb 2011 08:55:00 PM UTC, comment #3: 

Closing as Works For Me.

Eric Weddington <arcanum>
Project AdministratorIn charge of this item.
Wed 09 Jun 2010 05:37:06 PM UTC, comment #2: 

I had a similar problem, which I think was due to an incorrect patch.  There was a wildcard in one of the config / header files which incorrectly pulled some of the MCU types into the wrong AVR architecture group.  When I replaced the wildcard with the individual mcu names (in their respective categories), the problem went away.  Not sure if this was the case here.

David A. Mellis <mellis>
Wed 09 Jun 2010 08:25:29 AM UTC, comment #1: 

We've never heard about similar problems from anybody else.

Does this problem still persist?

Joerg Wunsch <joerg_wunsch>
Project Administrator
Mon 10 Mar 2008 07:47:29 PM UTC, original submission:  

With fully patched binutils 2.18 and gcc 4.2.2 under 32bit Ubuntu Linux 7.10 I did a clean build of avr-libc 1.6.1.

When build an application for either the AT90USB162 or AT90USB82 I get the following linker error:

/usr/local/lib/gcc/avr/4.2.2/../../../../avr/bin/ld: crtusb162.o: No such file: No such file or directory

This actually object file is here:

$ locate crtusb162.o
/usr/local/avr/lib/avr5/crtusb162.o

If I manually copy:

/usr/local/avr/lib/avr5/crtusb162.o

to

/usr/local/avr/lib/avr35/crtusb162.o

it links correctly. Also if I remove the gcc-avr35.patch and rebuild avr-libc and my application it links correctly.

Looks like an avr-libc build/install problem with that avr35 patched version of gcc.

Brad Schick <schickb>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by arcanum (Posted a comment)
  • -email is unavailable- added by mellis (Posted a comment)
  • -email is unavailable- added by joerg_wunsch (Posted a comment)
  • -email is unavailable- added by schickb (Submitted the item)
  • -email is unavailable- added by schickb
  •  

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2011-02-22 arcanum StatusNeed Info => Works For Me
        Assigned toNone => arcanum
        Open/ClosedOpen => Closed
    2010-06-09 joerg_wunsch StatusNone => Need Info
        ReleaseNone => 1.6.1
    2008-03-10 schickb Carbon-Copy- => Added schickb

    Back to the top


    Powered by Savane 3.7