buggNewSense GNU/Linux - Bugs: bug #29521, Older versions of user-defined...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #29521: Older versions of user-defined packages missing

Submitted by:  Sam Geeraerts <samgee>
Submitted on:  Sun 11 Apr 2010 07:00:00 PM UTC  
 
Category: BuilderSeverity: 5 - Blocker
Item Group: Package archiveStatus: Invalid
Privacy: PublicAssigned to: None
Open/Closed: Closed

Fri 12 Jul 2013 04:49:08 PM UTC, comment #4:

Fool! The GPL says it's cool if the source is available at the same location for every binary that is offered. Both the package repository and cdimage comply with that. For the GPL it doesn't matter if old versions are deleted, as long as we don't leave any stray binaries.

Always keeping just one version can be annoying for people in the middle of downloading the version that gets replaced. With the number of users we have I don't expect this to be a problem anytime soon.

Sam Geeraerts <samgee>
Project Administrator
Wed 14 Apr 2010 08:11:45 PM UTC, comment #3:

OK, just a readme file would be enough [1]. Clear and convenient instructions means pointing to revision numbers for every binary, I guess.

[1] http://www.gnu.org/licenses/gpl-faq.html#SourceInCVS

Sam Geeraerts <samgee>
Project Administrator
Wed 14 Apr 2010 08:01:58 PM UTC, comment #2:

GPLv3 section 6d says that if the source code is on a different server that there must be "clear directions next to the object code saying where to find the Corresponding Source". Pointing to Builder in a readme file would satisfy that requirement, but not "equivalent copying facilities", I think.

Sam Geeraerts <samgee>
Project Administrator
Tue 13 Apr 2010 10:07:14 AM UTC, comment #1:

when you say 'user defined packages', do yu mean packages generated out of builder? your later comments make me confused.

if that is true, its not a gpl violation. the source can be acquired by doing a builder checkout.

Karl Goetz <kgoetz>
Sun 11 Apr 2010 07:00:00 PM UTC, original submission:

All user-defined packages only have their latest version in the repository now. This is a GPL violation. We should keep at least the source of older versions.

We keep the source of our non-Ubuntu packages in builder/packages/deltah. Builder only builds the latest version of these packages. I think this works fine as long generated versions remain untouched. But when the repo needs to be (partially) regenerated (e.g. because of reprepro db corruption) then the older versions don't get regenerated.

At first glance, I'd say we need to keep the building of user-defined packages out of Builder and implement something similar to metad's setup instead.

Sam Geeraerts <samgee>
Project Administrator

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by samgee (Submitted the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 12 Jul 2013 04:49:08 PM UTCsamgeeStatusConfirmed=>Invalid
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup