bugMHonArc - Bugs: bug #32665, allow message display to wrap...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #32665: allow message display to wrap (simple HTML change)

Submitted by:  S Page <skierpage>
Submitted on:  Thu 03 Mar 2011 05:32:25 AM UTC  
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Undesired Behavior
Status:  Wont Fix Privacy:  Public
Assigned to:  None Open/Closed:  Closed
Operating System:  Linux Perl Version:  unknown
Component Version:  2.6.18 Fixed Release:  N/A

Fri 04 Mar 2011 05:38:14 PM UTC, comment #2:

Read the MIMEFILTERS resource page of the documentation
to find options to the plain text filter to specify
maximum line lengths.

If you want to do the CSS approach, you can modify the
page layout to include your own CSS stylesheet, and
apply the attribute to pre elements in the message
pages:

pre {
white-space: pre-wrap;
}

See the Page Layout section of the documentation on how
to modify the HTML created so you can include your own
CSS reference (or inline the CSS in the header).

IMO, wrapping of the text is an archive administrator
decision, and not something the mhonarc should always
do. The above provides information on how to achieve
the effect you want w/o modifications to source code.

Earl Hood <ehood>
Project Administrator
Thu 03 Mar 2011 05:35:29 AM UTC, comment #1:

(Sorry, my first bug report on savannah, not used to its markup.)
I wanted the rest of my submission to read

,change
This does not affect copy and paste of long lines and does not involve processing or changing the text within the pre tag in any way. It just makes many more messages readable!

Mailman had the same bug and has incorporated this bug fix for some time, see https://bugs.launchpad.net/mailman/+bug/266467

Earlier bug #13276: "Archive of mail lists does not text wrap in the Browser" seems to refer to the same issue. It was closed as Not a Bug with the comment "MHonArc provides options to deal with mis-behaved MUA's that do not properly format text messages." I'm not familiar with MHonArc admin, but this pre style fixes the problem with no downside.

S Page <skierpage>
Thu 03 Mar 2011 05:32:25 AM UTC, original submission:

I browse the archives of mailing lists created by MHonArc.
Many messages to mailing lists that use its ASCII preformatted display are not word-wrapped and so each paragraph appears as a few unreadably long lines in all browsers. See for example http://mail.gnome.org/archives/gnome-shell-list/2011-February/msg00192.html , http://mail.gnome.org/archives/gnome-shell-list/2011-February/msg00225.html , etc.

The fix is easy, just change the PRE tag to invoke the CSS white-space handling:
<pre style="white-space: pre-wrap">
I'm not positive but this might be line 557 in lib/mhtxtplain.pl, change

S Page <skierpage>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ehood (Posted a comment)
  • -email is unavailable- added by skierpage (Submitted the item)
  • -email is unavailable- added by skierpage
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2011-03-05 ehood Open/ClosedOpen => Closed
    2011-03-04 ehood StatusNone => Wont Fix
        Fixed Release => N/A
    2011-03-03 skierpage Carbon-Copy- => Added skierpage

    Back to the top


    Powered by Savane 3.3