buggNewSense GNU/Linux - Bugs: bug #32954, Konqueror redirects to...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #32954: Konqueror redirects to microsoft.com

Submitted by:  Sam Geeraerts <samgee>
Submitted on:  Wed 30 Mar 2011 06:51:47 PM UTC  
 
Category: gNewSense 2.xSeverity: 4 - Important
Item Group: i386Status: Wont Fix
Privacy: PublicAssigned to: Sam Geeraerts <samgee>
Open/Closed: Closed

(Jump to the original submission Jump to the original submission)

Sun 22 Dec 2013 09:48:29 PM UTC, comment #12:

I'm going to retire DeltaH.

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Wed 02 Jan 2013 06:27:49 PM UTC, comment #11:

I found on the Web that the g++ error could be caused by lack of free memory. I shut off the biggest memory hog (loggerhead) on seagoon and let it run again. Build ends with the same internal error at the same place. I'd expected a memory problem to be more random.

I'll focus on kde4libs now. If that works we can still have one of the KDE variants.

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Mon 31 Dec 2012 04:52:59 PM UTC, comment #10:

dpkg-buildpackage after manual automake still fails, on dcopserver.moc this time.

(file #27173)

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Mon 31 Dec 2012 03:59:52 PM UTC, comment #9:

Straight dpkg-buildpackage complains about target knsplugininstaller.cpp. That file does not exist, but khtml/misc/Makefile.in lists it in dependencies. After regenerating all Makefile.in (running 'automake' in top dir) it no longer lists the cpp in dependencies.

(file #27172)

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Mon 31 Dec 2012 01:27:25 PM UTC, comment #8:

Log excerpt doesn't take, so attached it.

The error might be caused by building in a linux32 chroot. I tried a test build on my Deltah machine, but that also ends with an error (suggesting that Makefile.in aren't properly regenerated). Will do more tests.

(file #27171)

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Mon 31 Dec 2012 01:20:07 PM UTC, comment #7:

Trying again. From Builder's log:

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Mon 31 Dec 2012 01:15:52 PM UTC, comment #6:

Compilation of kdelibs ends with some vague error. From Builder's log:

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Sun 23 Dec 2012 10:46:14 AM UTC, comment #5:

Thanks, Andrew.

For testing: the snapkeys link doesn't show the symptom anymore, see http://www.walkernews.net/2008/08/17/windows-media-player-how-to-embed-wmv-file-in-html-code/ instead.

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Sun 16 Dec 2012 07:49:05 PM UTC, comment #4:

This is reported as fixed in Parabola with links to the diffs in this Trisquel forum entry:

http://trisquel.info/en/forum/konqueror-bug-what-would-it-take#comment-28220

Andrew M. 'Leny' Lindley <leny2010>
Tue 26 Jul 2011 09:39:10 PM UTC, comment #3:

I contacted rms about it last month. He said that it's an issue and that it's supposed to be handled in IceCat, so we could just use IceCat. Let's interpret that as: do it like IceCat, meaning: letting the user know that a plugin is missing is good, but don't show links to (potentially) non-free software.

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Sat 04 Jun 2011 07:25:51 AM UTC, comment #2:

There's some disagreement about this in the free distro community [1]. Maybe we shouldn't try to fix this issue, because it's the website developer's suggestion.

[1] http://lists.nongnu.org/archive/html/gnu-linux-libre/2011-05/msg00007.html

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Wed 30 Mar 2011 06:52:51 PM UTC, comment #1:

This happens with both konqueror and konqueror-kde4.

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.
Wed 30 Mar 2011 06:51:47 PM UTC, original submission:

Konqueror redirects to microsoft.com when visiting a website with an embedded WMV video.

Steps to reproduce:
1) Uninstall any media player plugins for the browser, (e.g. totem-mozilla) and mozplugger.
2) Start Konqueror and browse to http://www.snapkeys.com/en/imaginaryinterface/letters
3) Konqueror shows a pop-up box saying: "Missing plugin - Konqueror. No plugin found for 'Microsoft Media Format'. Do you want to download one from http://www.microsoft.com? [Download] [Do Not Download]".
4) Click the download button. A new window opens on the URL https://www.microsoft.com/Windows/Downloads/Contents/MediaPlayer/. It probably offered a download of non-free software at some point, but now it says that the requested page cannot be found and shows the Bing search engine instead, with search results for Windows Media Player.

Expected: the pop-up box in step 3 should suggest installing a free media player/plugin. Alternatively it could be not shown at all.

Sam Geeraerts <samgee>
Project AdministratorIn charge of this item.

 

Attached Files
file #27173:  after_automake.log added by samgee (2kB - application/octet-stream)
file #27171:  build_kdelibs.txt added by samgee (2kB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by leny2010 (Posted a comment)
  • -unavailable- added by samgee (Submitted the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 22 Dec 2013 09:48:28 PM UTCsamgeeStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
    Wed 02 Jan 2013 06:27:49 PM UTCsamgeeStatusIn Progress=>None
    Mon 31 Dec 2012 04:52:59 PM UTCsamgeeAttached File-=>Added after_automake.log, #27173
    Mon 31 Dec 2012 03:59:52 PM UTCsamgeeAttached File-=>Added kdelibs_dpkg-buildpackage.txt, #27172
    Mon 31 Dec 2012 01:27:25 PM UTCsamgeeAttached File-=>Added build_kdelibs.txt, #27171
    Tue 26 Jul 2011 09:39:10 PM UTCsamgeeStatusConfirmed=>In Progress
      Assigned toNone=>samgee

    Back to the top


    Powered by Savane 3.1-cleanup