bugWeeChat - Bugs: bug #38346, Weechat shows some passwords in...

 
 

bug #38346: Weechat shows some passwords in the main window

Submitted by:  Juan Francisco Cantero Hurtado <juanfra684>
Submitted on:  Mon 18 Feb 2013 05:17:34 AM UTC  
 
Category: displaySeverity: 3 - Normal
Item Group: displayStatus: Fixed
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Open/Closed: Closed
Release: 0.4.0IRC nick: 

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Sat 23 Feb 2013 02:04:36 PM UTC, comment #7:

Task is actually not needed.

I improved the code by using new modifiers in IRC plugin, and new default rmodifiers.

See release notes for more info: http://weechat.org/files/releasenotes/ReleaseNotes-devel.html

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Tue 19 Feb 2013 10:06:50 PM UTC, comment #6:

OK, you are right, I found the code doing that.

So please open a task, as I consider it's not really a bug, but something missing. And then I'll code something more clean, that you can adjust (maybe using a rmodifier).

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Tue 19 Feb 2013 08:51:26 AM UTC, comment #5:

I think this bug is invalidly resolved as invalid. it is NOT the server who does the stars. (but it is also NOT rmodifier)

weechat has a dirty hack in the irc command parser that stars out the password if you /msg nickserv, but ONLY on identify or register messages.

there is actually no way for the server to star out a password in a message that the user sent.

Anonymous
Mon 18 Feb 2013 11:32:22 PM UTC, comment #4:

OK, thanks for the explanation :)

Juan Francisco Cantero Hurtado <juanfra684>
Mon 18 Feb 2013 01:53:11 PM UTC, comment #3:

OK, got it.

The rmodifier plugin only hides password in the command line, and text saved in history of commands (that you can recall with up key).
I does not hide passwords in the chat area (where IRC messages are displayed).
When you do /msg nickserv identify, the stars are sent by the server, so I think server should send stars for ghost too.
For me the problem is on server side.

By the way, you can create or change rmodifiers yourself (even for messages displayed in chat area), it's dynamic, so it's not a bug for me if some things are not hidden by default, user can add them (and for common things, I can add them by default if needed).

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Mon 18 Feb 2013 01:17:16 PM UTC, comment #2:

I've tried the command you suggested but it doesn't work.

http://juanfra.info/bugs-y-listas/weechat-201302/rmodifier.conf

Juan Francisco Cantero Hurtado <juanfra684>
Mon 18 Feb 2013 09:07:44 AM UTC, comment #1:

This is supposed to work by default (password after "ghost nick" should be hidden).

Maybe you have old rmodifiers in your config, so if you didn't change them (or add new ones), just restore default rmodifiers with command:

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Mon 18 Feb 2013 05:17:34 AM UTC, original submission:

Weechat hides the password in "/msg nickserv identify 1234" but doesn't hide the password of other commands like "/msg nickserv ghost mynick 1234". The problem is weechat saves the logs with the password in clear text.

05:51:19 freenode -- | MSG(nickserv): ghost mynick 1234
05:51:19 freenode -- | MSG(nickserv): identify **********

Can you add the same filter to the "ghost" command?. Thanks! :)

Juan Francisco Cantero Hurtado <juanfra684>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by flashcode (Posted a comment)
  • -unavailable- added by juanfra684 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 20 May 2013 09:01:21 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Sat 23 Feb 2013 02:04:36 PM UTCflashcodeStatusInvalid=>Fixed
    Mon 18 Feb 2013 09:07:44 AM UTCflashcodeCategoryother=>display
      Item Groupirc protocol=>display
      StatusNone=>Invalid
      Assigned toNone=>flashcode

    Back to the top


    Powered by Savane 3.1-cleanup