bugWeeChat - Bugs: bug #39117, hardcoded weechat.log

 
 

bug #39117: hardcoded weechat.log

Submitted by:  None
Submitted on:  Wed 29 May 2013 03:40:58 PM UTC  
 
Category:  logger plugin Severity:  3 - Normal
Item Group:  other Status:  Invalid
Privacy:  Public Assigned to:  Sebastien Helleu <flashcode>
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  0.4.1
IRC nick: 

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 29 May 2013 03:45:07 PM UTC, comment #1:

The file "weechat.log" is a "system" WeeChat log file, it is not managed by logger plugin, but by WeeChat itself. There is almost nothing in this file.

Other log files (logs of buffers) are managed by logger plugin and then use the option logger.file.path.

So for me this is not a bug, but normal behaviour.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Wed 29 May 2013 03:40:58 PM UTC, original submission:

weechat.log is always in ~/.weechat/weechat.log

It would be much better to get unified behavior for logging: all the logs should go into logger.file.path

Alternatively there should be command-line option available to specify desired weechat.log location or completely disable creation of this log file.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by flashcode (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-10-06 flashcode Open/ClosedOpen => Closed
    2013-05-29 flashcode Item GroupNone => other
        StatusNone => Invalid
        Assigned toNone => flashcode

    Back to the top


    Powered by Savane 3.3