bugWeeChat - Bugs: bug #39368, characters are disappear in topic...

 
 

bug #39368: characters are disappear in topic by using color code 02

Submitted by:  Pseudo Nym <muxmouse>
Submitted on:  Sun 30 Jun 2013 02:34:57 AM UTC  
 
Category:  irc plugin Severity:  3 - Normal
Item Group:  display Status:  Invalid
Privacy:  Public Assigned to:  Sebastien Helleu <flashcode>
Originator Name:  Open/Closed:  Closed
Release:  0.4.1 IRC nick:  MuxMouse

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 10 Jul 2013 11:24:25 AM UTC, comment #4:

In fact blue on a blue background will be insivisible in the default title bar.

Moreover, another bug was happening: bug #38193

Using 256 colors in terminal/WeeChat solves the problem.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Wed 10 Jul 2013 06:44:30 AM UTC, comment #3:

I tried with your string (in devel version), and the topic displays fine.
If you have other info to give me in order to reproduce the problem, please tell me.
Or maybe try to set such topic on a channel, and I'll join this channel to check if it's OK for me (please contact me on freenode #weechat if needed).

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Sat 06 Jul 2013 12:21:55 PM UTC, comment #2:

http://www.weechat.org/files/doc/stable/weechat_user.en.html --> 3.8.2. Color codes

Code 02 stands there for darkblue. I try this "/topic C02(C01testC02)" and the open bracket is absent. I try "/topic C02(C05testC02)" and both brackets are absent.

Pseudo Nym <muxmouse>
Sat 06 Jul 2013 06:42:35 AM UTC, comment #1:

Code 02 is bold in IRC.

I tried to use bold in a topic, with command:

And the topic just displays fine, so it works for me.

I tried with option irc.look.topic_strip_colors on/off, both values are OK.

I tried with code 03 (which is for a color number), works fine too.

Can you give me an example of topic or command you do, that would cause problems?

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Sun 30 Jun 2013 02:34:57 AM UTC, original submission:
Pseudo Nym <muxmouse>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by flashcode (Posted a comment)
  • -email is unavailable- added by muxmouse (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-10-06 flashcode Open/ClosedOpen => Closed
    2013-07-10 flashcode StatusWorks For Me => Invalid
    2013-07-06 flashcode Categorydisplay => irc plugin
        Item GroupNone => display
        StatusNone => Works For Me
        Assigned toNone => flashcode

    Back to the top


    Powered by Savane 3.3