bugWeeChat - Bugs: bug #40907, Error when compiling perl support

 
 

bug #40907: Error when compiling perl support

Submitter:  None
Submitted:  Mon 16 Dec 2013 09:05:15 AM UTC
 
Category:  compilation Severity:  3 - Normal
Item Group:  compile/install Status:  Invalid
Privacy:  Public Assigned to:  flashcode
Originator Name:  Originator Email:  * -email is unavailable-
Open/Closed:  Closed Release:  * 0.4.2
IRC nick: 
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Mon 16 Dec 2013 09:58:45 AM UTC, comment #5: 

OK, then I close the bug.

Sebastien Helleu <flashcode>
Project Administrator
Mon 16 Dec 2013 09:54:42 AM UTC, comment #4: 

Confirmed. Once I fixed my perl environment I had no problems compiling WeeChat with perl support.

Anonymous
Mon 16 Dec 2013 09:34:19 AM UTC, comment #3: 

I think you're right. The issue is my perl environment. Once I get things fixed up I'll re-open this if the issue persists.

Anonymous
Mon 16 Dec 2013 09:24:40 AM UTC, comment #2: 

Yes I do believe /usr/local/lib is where Perl goes by default on CentOS.

[xxxxxx@localhost ~]$ which perl
/usr/local/bin/perl

[xxxxxx@localhost perl5]$ pwd
/usr/local/lib/perl5
[xxxxxx@localhost perl5]$ ls -la
total 16
drwxr-xr-x   4 root root 4096 Nov 27 09:46 .
drwxr-xr-x.  9 ntop ntop 4096 Nov 27 09:46 ..
drwxr-xr-x  59 root root 4096 Nov 27 09:46 5.18.1
drwxr-xr-x   3 root root 4096 Nov 27 09:46 site_perl

I'll have to do a quick VM build to confirm. I do remember a little while ago mucking with Perl and I wonder if I've broken something.

Anonymous
Mon 16 Dec 2013 09:14:45 AM UTC, comment #1: 

Hi,

I'm not sure this is a WeeChat problem, because the error says:

/usr/local/lib/perl5/5.18.1/x86_64-linux/CORE/libperl.a: could not read symbols: Bad value

which is not a WeeChat file, but from your perl install.

Is it normal that your perl is in /usr/local/lib and not /usr/lib/ ? Is it the standard CentOS perl install ?

Sebastien Helleu <flashcode>
Project Administrator
Mon 16 Dec 2013 09:05:15 AM UTC, original submission:  

Running CentOS 6.5 64-bit with Perl 5.18.1.

When running 'make' I get the following:

...
[ 78%] Building C object src/plugins/xfer/CMakeFiles/xfer.dir/xfer-upgrade.o
Linking C shared module xfer.so
[ 78%] Built target xfer
[ 79%] Building C object src/plugins/perl/CMakeFiles/perl.dir/weechat-perl.o
[ 79%] Building C object src/plugins/perl/CMakeFiles/perl.dir/weechat-perl-api.o
Linking C shared module perl.so
/usr/bin/ld: /usr/local/lib/perl5/5.18.1/x86_64-linux/CORE/libperl.a(op.o): relocation R_X86_64_32S against `PL_sv_yes' can not be used when making a shared object; recompile with -fPIC
/usr/local/lib/perl5/5.18.1/x86_64-linux/CORE/libperl.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[2]: *** [src/plugins/perl/perl.so] Error 1
make[1]: *** [src/plugins/perl/CMakeFiles/perl.dir/all] Error 2
make: *** [all] Error 2

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by flashcode (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-12-16 flashcode StatusNeed Info Invalid
        Open/ClosedOpen Closed
    2013-12-16 flashcode StatusNone Need Info
        Assigned toNone flashcode

    Back to the top


    Powered by Savane 3.9