bugThe FreeType Project - Bugs: bug #41959, freetype2.pc needs improvements

 
 

bug #41959: freetype2.pc needs improvements

Submitted by:  wesley <wesley>
Submitted on:  Wed 26 Mar 2014 02:52:08 AM UTC  
 
Severity:  3 - Normal Item Group:  Hack required
Status:  Duplicate Privacy:  Public
Assigned to:  Werner LEMBERG <wl> Open/Closed:  Closed
Planned Release:  None

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 26 Mar 2014 06:35:49 PM UTC, comment #1:

Duplicate of #38235.

Note that your suggestion doesn't work for the reasons given in referenced bug report. Any help in implementing the suggested solution is highly welcome :-)

Werner LEMBERG <wl>
Project AdministratorIn charge of this item.
Wed 26 Mar 2014 02:52:08 AM UTC, original submission:

Hello there,
I found it unable to compile those C files with MinGW-w64 which includes ft2build.h because the pkg-config.exe is generating a wrong including path.
Recently, the freetype2.in looks like this.
includedir="%includedir%/freetype2"
And freetype2.pc looks like this after I "./configure --prefix=/opt".
includedir="/opt/include/freetype2"
It may be OK in Linux. But in Windows, "/opt" is just a relative directory and it doesn't exist. This is the root cause.
I've checked some other open source projects. They generate .pc files like this.
prefix=/opt
includedir=${prefix}/include
When "/opt" goes in, it will find the real path automatically. So I don't have to care about which path I pass to --prefix, even if ${prefix} is extracted to "/opt" like this,
includedir=/opt/include
also works fine.

Here's my suggestion. For more cross-platform, please consider modify the file freetype-2.5.3/builds/unix/freetype2.in. Simply removing the quote marks will do it perfectly.

wesley <wesley>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by wl (Posted a comment)
  • -email is unavailable- added by wesley (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-03-26 wl StatusNone => Duplicate
        Assigned toNone => wl
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.3