buggNewSense GNU/Linux - Bugs: bug #42777, Use of IceCat results in...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #42777: Use of IceCat results in recommendation of installing non-free plugin

Submitted by:  John Scott <fuzzytoothpaste>
Submitted on:  Tue 15 Jul 2014 05:00:45 PM UTC  
 
Category: gNewSense 3Severity: 3 - Normal
Item Group: All architecturesStatus: Need Info
Privacy: PublicAssigned to: None
Open/Closed: Open

Wed 16 Jul 2014 09:34:42 PM UTC, comment #2:

It's very likely that you're experiencing a known issue, also with other browsers (e.g. bug #37974). Flash media are often wrapped in object/embed HTML elements. With the "pluginspage" attribute the author of the website can suggest a plugin download link. Browsers can relay that link when there is no plugin installed to view the media. There's already been some discussion about whether this is bug should be solved in browsers or in website authors [1].

If you're sure that the issue you're seeing is not related to the pluginspage attribute but coming from the browser itself, then please provide more details. Also check if you're using gNewSense's browser: it comes with a modified Iceweasel, not with IceCat.

[1] https://lists.nongnu.org/archive/html/gnu-linux-libre/2011-05/msg00007.html

Sam Geeraerts <samgee>
Project Administrator
Tue 15 Jul 2014 05:11:32 PM UTC, comment #1:

I would like to point out that because there is no Adobe Shockwave Player for GNU/Linux, this needs to be fixed much more badly now.

John Scott <fuzzytoothpaste>
Tue 15 Jul 2014 05:00:45 PM UTC, original submission:

If you use the IceCat web browser (which comes included with gNewSense 3) to navigate to a page that requires the Adobe Shockwave Player, IceCat will recommend installing the plugin. Although Adobe currently does not make an official build of Adobe Shockwave Player for GNU/Linux, this may encourage the user to find a way to install it anyway, such as downloading the Microsoft Windows version of the plugin and a browser and running them with Wine. Although this is not very major, this still needs to be fixed.

John Scott <fuzzytoothpaste>

 

Attached Files
file #31724:  Recommend.png added by fuzzytoothpaste (50kB - image/png - This is a screenshot I took while running the latest version of gNewSense inside of Oracle VM VirtualBox.)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by samgee (Posted a comment)
  • -unavailable- added by fuzzytoothpaste (Submitted the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 16 Jul 2014 09:34:42 PM UTCsamgeeStatusNone=>Need Info
    Tue 15 Jul 2014 05:01:31 PM UTCfuzzytoothpasteCarbon-CopyRemoved -unavailable-=>-
    Tue 15 Jul 2014 05:00:45 PM UTCfuzzytoothpasteAttached File-=>Added Recommend.png, #31724
      Carbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup