bugLernsoftware Filius - Bugs: bug #47461, DHCP funktioniert nicht mit sehr...

 
 

bug #47461: DHCP funktioniert nicht mit sehr vielen Rechnern

Submitted by:  Stefan Freischlad <sfreischlad>
Submitted on:  Fri 18 Mar 2016 08:17:10 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 18 Mar 2016 08:17:55 PM UTC, comment #1: 

Ich habe mir das Problem mit dem Debugger angesehen. Das scheint mit den Laufzeiten zusammen zu hängen. Der Ablauf bei DHCP ist wie folgt:
1. Der Client signalisiert, dass er eine IP-Adresse benötigt (DHCPDISCOVER).
2. Der Server gibt eine verfügbare IP-Adresse zurück und merkt sich diese für eine bestimmte Zeit (DHCPOFFER).
3. Der Client prüft, ob im Rechnernetz schon ein anderer Rechner die IP-Adresse hat, indem er eine ARP-Anfrage für die IP-Adresse ins Rechnernetz stellt (sowas wie "Wer kann mir die MAC-Adresse zur IP-Adresse xy geben?"). Nach Versand der Anfrage muss der Rechner eine bestimmte Zeit auf Antworten fragen.
4. Nach Ablauf der Wartezeit zur ARP-Anfrage schickt der Client die Anforderung an den Server, dass er die angebotene Adresse verwenden möchte (DHCPREQUEST).
5. Der Server schaut nach, ob er dem Client diese Adresse angeboten hat. Wenn dies der Fall ist, bestätigt er die Anfrage (DHCPACK). Wenn nicht, lehnt er dies ab (DHCPNACK).

Das Problem liegt darin, dass der Server sich die angebotenen IP-Adressen nur eine bestimmte Zeit merkt. Der Client fordert aber die Adresse erst an (DHCPREQUEST), nachdem die Zeit abgelaufen ist - der Server die Reservierung also bereits 'vergessen' hat. Weil der Server nicht mehr weiß, dass er diesem Client die Adresse angeboten hat, lehnt er die Anfrage ab.

Stefan Freischlad <sfreischlad>
Project Administrator
Fri 18 Mar 2016 08:17:10 PM UTC, original submission:  

Ich würde Ihnen zur veranschaulichung gern das Projekt schicken. Es handelt sich um 36 Rechner + 4 Server. die 4 Server bekommen eine feste IP zugewiesen, der Rest durch den DHCP. Beim abspielen bekommen leider nicht alle eine IP vom DHCP zugewiesen, obwohl die Range doch ausreichen müsste. Wenn ich jeden Switch erst einzeln und nacheinander an den Hauptswitch anschließe bekommen die nacheinander IP's aus der festgelegten Range, doch wenn ich den letzten Switch anschließ bekommen nur noch ein Teil der Rechner IP's zugewiesen.

Stefan Freischlad <sfreischlad>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #36692:  Testnetzwerk.fls added by sfreischlad (25KiB - application/octet-stream - Ich habe mir das Problem mit dem Debugger angesehen. Das scheint mit den Laufzeiten zusammen zu hängen. Der Ablauf bei DHCP ist wie folgt: 1. Der Client signalisiert, dass er eine IP-Adresse benötigt (DHCPDISCOVER). 2. Der Server gibt eine verfügbare IP-A)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by sfreischlad (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-03-18 sfreischlad Attached File- => Added Testnetzwerk.fls, #36692

    Back to the top


    Powered by Savane 3.5