bugAVR In-System Programmer - Bugs: bug #14040, uisp fails wth atmega48 and stk200...

 
 

bug #14040: uisp fails wth atmega48 and stk200 under windows xp pro on ibm thinkpad

Submitted by:  None
Submitted on:  Thu 04 Aug 2005 11:40:39 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Originator Email: -unavailable-Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 21 Nov 2006 12:29:52 AM UTC, comment #3:

I also get the same result while flashing through a dasa cable (straight to serial port) The same hardware and .hex file works when flashing with avrdude.

Everything works correctly when using an atmega88

Anonymous
Sun 13 Nov 2005 07:58:07 PM UTC, comment #2:

New entry in the header avr.h

#define AVR_M48 ( AVR_PAGE_POLL | AVR_LOCK_BOOT | AVR_FUSE_RD \
| AVR_FUSE_NEWWR | AVR_CAL_RD | AVR_FUSE_HIGH)

Changed in Avr.c

{ "ATmega48", 0x92, 0x05, 4096, 64, 256, 4000, 4000, AVR_M48 },

so long ... Uli
http://www.uroehr.de

Anonymous
Sun 13 Nov 2005 07:54:02 PM UTC, comment #1:

The ATMEGA48 ist defined wrong in the avr.c File. It has no single byte programming feature. If you disable this in the Header File (flag) and set the Pagesize to 64 everything works perfect.

so long ... Uli

Anonymous
Thu 04 Aug 2005 11:40:39 PM UTC, original submission:

Running latest 20050207 included with WinAVR. Recognizes the device fine, programming fails. See below

C:\avr\lcd_try>uisp -dlpt=0x3bc -dprog=stk200 -v=3 --erase --upload if=lcd.hex
Reset inactive time (t_reset) 1000 us
AVR Direct Parallel Access succeeded after 0 retries.
Vendor Code: 0x1e
Part Family: 0x92
Part Number: 0x05
Atmel AVR ATmega48 is found.
Page Write Disabled
FLASH Write Delay (t_wd_flash): 11111 us
EEPROM Write Delay (t_wd_eeprom): 11111 us
Erasing device ...
Reinitializing device
AVR Direct Parallel Access succeeded after 0 retries.
Vendor Code: 0x1e
Part Family: 0x92
Part Number: 0x05
Atmel AVR ATmega48 is found.
Page Write Disabled
FLASH Write Delay (t_wd_flash): 11111 us
EEPROM Write Delay (t_wd_eeprom): 11111 us
Uploading: flash
#Error: Data polling readback status: write=0x0c read=0xff
If device was erased disable polling with the -dno-poll option.

Hardware works fine with CodeVisionAVR demo. Using install_giveio.bat included with WinAVR to get port access. It appears to not have any issues erasing - and the read works properly. Please let me know if you need any more info.

Thanks,
Zac

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

Follows 1 latest change.

Date Changed By Updated Field Previous Value => Replaced By
Thu 04 Aug 2005 11:40:39 PM UTCNoneCarbon-Copy-=>Added zac --DOT-- wheeler --AT-- homecomfortzones --DOT-- com

Back to the top


Powered by Savane 3.1-cleanup