bugGlobulation 2 - Bugs: bug #26420, BiDi problem: Arabic letters won't...

 
 

bug #26420: BiDi problem: Arabic letters won't merge together

Submitted by:  Leo Wandersleb <giszmo>
Submitted on:  Sat 02 May 2009 10:41:39 AM UTC  
 
Severity: 3 - NormalStatus: Confirmed
Assigned to: NoneOpen/Closed: Open
Release: 0.9.4 (Beta 4)Operating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 02 May 2009 10:41:39 AM UTC, original submission:

found on the forum here http://globulation2.org/forums/viewtopic.php?f=3&t=329&start=0&st=0&sk=t&sd=a :

Well I actually don't know whether it has really to do with BiDi, as the characters render as expected from right to left. But the problem is that they are separate.
I'm about to translate glob2 into Persian, and as you probably know, Persian uses Arabic alphabet; which its letters, unlike Hebrew (which is also right-to-left), sometimes (most of the times) stick together and form a unified shape. For example, the Persian translation for "Defense Tower" would be "برج مراقبت", but right now it will show up as "ب ر ج م ر ا ق ب ت" i.e. characters are not merged.
I'm a little frustrated by this problem. Because until it get solved, the Persian (and Arabic) translation would be useless.

I have the latest beta (0.9.4.1). I had this problem in 0.9.3 and 0.8.21 which I had before, and had installed both of them from my Debian repository. But I have compiled the new version myself (having libfribidi-dev (and lib-fribidi) installed) and the problem still resists.

Is it a bug? or something wrong in my system? because I searched for the problem and it seems that it have happened to no one else than me!
I even saw the Arabic translation contributor's weblog (http://the-very-end.blogspot.com/2007/06/globulation-in-arabic.html) and the letters in the screenshots were rendered correctly! He says one needs "to get latest fribidi from CVS in order to find arabic character shaped correctly". as the post dates back to June 2007, I don't think I still need to get the fribidi from CVS when the fribidi installed in my system is probably newer than the one in CVS in 2007 (which WORKED!). ...or do I need to do so?! :( Is it even fribidsi's fault?! My fribidi version is 0.10.9-1 (the one in Debian Lenny)

Thanks in advance.

The problem was confirmed by Zenfur.

Leo Wandersleb <giszmo>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by giszmo (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup