bugWeeChat - Bugs: bug #37757, Garbeled Display Needs Constant...

 
 

bug #37757: Garbeled Display Needs Constant Rewdraw

Submitted by:  BullShark (Freenode and Windfyre <bullshark>
Submitted on:  Fri 16 Nov 2012 02:23:18 PM UTC  
 
Category: displaySeverity: 3 - Normal
Item Group: displayStatus: Invalid
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Open/Closed: Closed
Release: 0.3.8IRC nick: BullShark

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 11 Jan 2013 08:10:50 PM UTC, comment #2:

Marking bug as "invalid". If you have new info, please add a comment.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Mon 19 Nov 2012 10:13:29 PM UTC, comment #1:

Launching weechat-curses from a shell seems to fix this instead of directly from .screenrc. My default shell I tested with is zsh. I will try /bin/zsh -c "weechat-curses" in my .screenrc to see if this fixes it.

BullShark (Freenode and Windfyre <bullshark>
Fri 16 Nov 2012 02:23:18 PM UTC, original submission:

I'm having a problem with weechat's display being corrupted. Redraws are needed with control + l to fix the display. But less than a minute later, new text appearing in weechat causes the display to become corrupt again and need another redraw.

This problem doesn't happen every time I run weechat. I have my DE configured that when I login to it, It launches a terminal emulator running screen. screen then reads my user's .screenrc which runs weechat-curses in one of its windows. When I relogin to my DE without rebooting, this causes another instance of weechat-curses attempted to be ran. Even if I closed the first one or the first one is still running and the second one fails to run, this is when the problems seem to start happening. This corrupted display problem I described does not happen every time I run weechat. I think it's triggered by what I described above.

I have tried unloading all plugins/scripts (except for core ones included with weechat) installed from weechat.org/scripts. I have tried running weechat with screen+xterm. Neither of these eliminated the problem.

My distro: Fedora 16
Weechat version: several tried
Kernel: 3.6.6-1.fc16.x86_64

BullShark (Freenode and Windfyre <bullshark>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #26922:  weechat 0.3.7_021.png added by bullshark (912kB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by flashcode (Posted a comment)
  • -unavailable- added by bullshark (Submitted the item)
  • -unavailable- added by bullshark
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 20 Jan 2013 09:20:50 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Fri 11 Jan 2013 08:10:50 PM UTCflashcodeStatusNone=>Invalid
      Assigned toNone=>flashcode
    Fri 16 Nov 2012 02:23:18 PM UTCbullsharkAttached File-=>Added weechat 0.3.7_021.png, #26922
      Carbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup