bugWeeChat - Bugs: bug #38215, Weechat relay sync/desync not...

 
 

bug #38215: Weechat relay sync/desync not working as specified

Submitted by:  None
Submitted on:  Thu 31 Jan 2013 11:52:07 PM UTC  
 
Category: relay pluginSeverity: 3 - Normal
Item Group: otherStatus: Fixed
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Keith JohnsonOriginator Email: -unavailable-
Open/Closed: ClosedRelease: 0.4.0
IRC nick: ubergeek42

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 03 Feb 2013 08:56:22 AM UTC, comment #3:

I think the problem is fixed, I fixed 3 bugs, see my commit message for more info: http://git.savannah.gnu.org/gitweb/?p=weechat.git;a=commitdiff;h=7a1f9a1d7

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Fri 01 Feb 2013 07:06:18 AM UTC, comment #2:

Hmm sorry, just looked at screenshot, you are sending "irc.freenode.#ubergeek42". So I'll look at problem and try to reproduce.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Fri 01 Feb 2013 07:04:20 AM UTC, comment #1:

When using sync or desync command you must give a full buffer name, ie: irc.freenode.#ubergeek42 (you said you sent: "freenode.#ubergeek42", which is not valid).
Can you try with full name, then tell me if bug is still there? In that case, I'll look at the problem.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Thu 31 Jan 2013 11:52:07 PM UTC, original submission:

See attached screenshot.
http://i.imgur.com/r2mXZYc.png

I have modified my client slightly, and it calls desync and desync * buffer,nicklist when it connects(To attempt to narrow down this bug)

Everything works as expected, I don't receive any _nicklist messages from weechat. Then I sync on a single channel(freenode.#ubergeek42, a test channel I use), but get the nicklist notifications for other channels that I am in.

Additionally, I sent a message in my test channel(#ubergeek42) while this client was connected, and no message was sent to the client. I believe it has only worked for me when calling 'sync' with no arguments to sync everything.

Looking at the code I don't see anywhere in the relay_weechat_protocol_*_nicklist_cb that it checks the buffers_sync variable to see if it should send this nicklist. The other issue of not sending messages for a 'sync'd buffer is more unusual, as that code appears to check the hashtable, but for some reason it isn't working(maybe the format for full buffer name is incorrect)?

This was tested with version 0.4.0-dev(compiled Nov 9th).

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by flashcode (Posted a comment)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 20 May 2013 09:02:12 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Sun 03 Feb 2013 08:56:22 AM UTCflashcodeStatusIn Progress=>Fixed
    Fri 01 Feb 2013 07:06:18 AM UTCflashcodeStatusNeed Info=>In Progress
    Fri 01 Feb 2013 07:04:20 AM UTCflashcodeItem GroupNone=>other
      StatusNone=>Need Info
      Assigned toNone=>flashcode
      Releaseother=>0.4.0

    Back to the top


    Powered by Savane 3.1-cleanup