bugWeeChat - Bugs: bug #38496, Bitlbee connection 127.0.0.1/6667...

 
 

bug #38496: Bitlbee connection 127.0.0.1/6667 breaks after 0.4.0

Submitted by:  Peter C <prime>
Submitted on:  Sun 10 Mar 2013 02:30:08 PM UTC  
 
Category: irc pluginSeverity: 3 - Normal
Item Group: irc protocolStatus: Fixed
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Open/Closed: Closed
Release: 0.4.0IRC nick: prime

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Wed 24 Jul 2013 06:58:34 AM UTC, comment #10:

Hi,

This problem was discussed some days ago on #weechat.
The problem comes from gnutls (it was verified by a user who downgraded gnutls, and it works fine).

So it's not a WeeChat issue.

By the way, same problem can happen with other software using gnutls, see: https://bugs.archlinux.org/task/36207

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Wed 24 Jul 2013 06:45:26 AM UTC, comment #9:

Hi, I seem to have a similar issue in Linux after upgrading to 0.4.1....

11:39:19 fnd =!= | irc: reading data on socket: error -24 Decryption has failed.
11:39:19 fnd -- | irc: disconnecting from server...
11:39:19 fnd -- | irc: disconnected from server
11:39:19 fnd -- | irc: reconnecting to server in 10 seconds

I'm using ArchLinux with WeeChat 0.4.1. Everything worked well with 0.4.0.

[user@machine ~]$ weechat-curses -v
0.4.1
[user@machine ~]$ uname -a
Linux machine 3.9.9-1-ARCH #1 SMP PREEMPT Wed Jul 3 22:45:16 CEST 2013 x86_64 GNU/Linux

SSL is on, SSL-Keysize is 1024 and SSL-Verify is off. The server which I'm connecting to is a bouncer (ZNC) instance. But the same WeeChat settings are working on other machines with 0.4.0.

I was directed here from stackexchange: http://unix.stackexchange.com/a/84113/19062

Afri Qhdoe <qdoe>
Fri 12 Apr 2013 10:49:57 AM UTC, comment #8:

The problem should be fixed. Thank you Pavel for the access on OS X machine, which helps me to fix the problem.

Pavel and Peter: please test latest git version and let me know if you still have problems.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Fri 22 Mar 2013 03:44:48 PM UTC, comment #7:

I'm currently connecting fine on weechat 3.9.2

Pavel Lishin <fancybone>
Fri 22 Mar 2013 03:40:59 PM UTC, comment #6:

Note: I deleted the attached bip_log.txt (with the password).

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Fri 22 Mar 2013 03:39:08 PM UTC, comment #5:

Hi Pavel,

According to this message in your bip log:

maybe it's related to the non-blocking mode of socket, that was added in 0.3.9.

Therefore I'm surprised that the problem is only in 0.4.0.

Could you please tell me in which version you have the problem?
Only 0.4.0 or 0.3.9 too?

And which is the latest version working fine: 0.3.8 or 0.3.9 ?

This will help me to track the changes that could cause such problem.

Thanks.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Fri 22 Mar 2013 03:22:57 PM UTC, comment #4:

whoops, just realized i gave away my throwaway password to an internal irc server locked away behind a firewall.

Pavel Lishin <fancybone>
Fri 22 Mar 2013 03:21:19 PM UTC, comment #3:

I'm having a similar issue connecting to bip (http://bip.milkypond.org/) instances, with very similar messages. At first, it would disconnect after the initial connection to a server, and then reconnect just fine - but now it repeatedly disconnects.

Like Peter C, I'm running OS X (though I'm on 10.7.5), and I installed 0.4.0 via Homebrew (WeeChat 0.4.0 [compiled on Mar 11 2013 11:54:00])

I've attached three files.

server_listfull.txt is the output of running /server listfull (well, cropped to the one server I was trying to connect to.)

weechat_connect.txt is the result of running /connect netomat; as you can see, it briefly connects and then has trouble reading data, and disconnects; it then tries to reconnect and fails again. (Note that the connection seems to be fine at first - I even get pestered by nickserv to identify myself.)

bip_log.txt is the output of the bip irc bouncer during my attempt to connect.

Note that while I had to restart bip on that particular server after a reboot of that machine (internal IRC server), another server on which I'm running bip hasn't been touched in weeks, so I'm pretty sure this is a weechat problem.

For now, I'll be rolling back to a previous version. Feel free to e-mail me, or contact me on freenode (nick fancybone) if any help with debugging is needed.

(file #27653, file #27654, file #27655)

Pavel Lishin <fancybone>
Tue 12 Mar 2013 11:32:26 AM UTC, comment #2:

I tested to see if it was one of the dozen or so scripts I had with no success by running weechat in a new configuration/debug or verbose launch to 127.0.0.1, where my bitlbee installation is. My bitlbee installation is local. I'm using homebrew package manager to install weechat (and all its dependencies) as well as bitlbee. I'm left thinking now maybe a dependency of weechat installed via homebrew is breaking what worked with 0.3.9.2.

Server: bb [not connected]
addresses. . . . . . : 'localhost'
proxy. . . . . . . . : ('')
ipv6 . . . . . . . . : (off)
ssl. . . . . . . . . : (off)
ssl_cert . . . . . . : ('')
ssl_priorities . . . : ('NORMAL')
ssl_dhkey_size . . . : (2048)
ssl_verify . . . . . : (on)
password . . . . . . : (hidden)
capabilities . . . . : ('')
sasl_mechanism . . . : ('plain')
sasl_username. . . . : ('')
sasl_password. . . . : (hidden)
autoconnect. . . . . : (off)
autoreconnect. . . . : (on)
autoreconnect_delay. : (10 seconds)
nicks. . . . . . . . : ('prime,prime-')
username . . . . . . : ('p')
realname . . . . . . : ('')
local_hostname . . . : ('')
command. . . . . . . : ('')
command_delay. . . . : (0 seconds)
autojoin . . . . . . : ('')
autorejoin . . . . . : (off)
autorejoin_delay . . : (30 seconds)
connection_timeout . : (60 seconds)
anti_flood_prio_high : (2 seconds)
anti_flood_prio_low. : (2 seconds)
away_check . . . . . : (5 minutes)
away_check_max_nicks : (25)
default_msg_part . . : ('nil')
default_msg_quit . . : ('nil')

Peter C <prime>
Mon 11 Mar 2013 07:27:32 AM UTC, comment #1:

Bitlbee is working fine for me (with any version, including 0.4.0 and 0.4.1-dev).
Can you paste output of /server listfull bb ? (hide any password in this output if needed).

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Sun 10 Mar 2013 02:30:08 PM UTC, original submission:

I'm running os x 10.8.2 with weechat 0.4.0 and bitlbee 3.2

When I ran weechat 0.3.9.2, bitlbee connected and then stayed connected, while in 0.4.0 it connects and immediately disconnects with this message.

10:28:51 bb -- | End of MOTD
10:28:51 bb -- | User mode [+s] by prime
10:28:51 bb =!= | irc: reading data on socket: error 22 (connection closed by peer)
10:28:51 bb -- | irc: disconnecting from server...
10:28:51 bb -- | irc: disconnected from server

I started to think it was something in weechat when I had the idea to test it from irssi which worked, so I rolled back to weechat 0.3.9.2 and when it worked there, I figure something in 0.4.0 is causing this to happen.

Please drop me a pm on freenode if you can address this.

Peter C <prime>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #27653:  server_listfull.txt added by fancybone (2kB - text/plain)
file #27655:  weechat_connect.txt added by fancybone (5kB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by qdoe (Posted a comment)
  • -unavailable- added by fancybone (Updated the item)
  • -unavailable- added by flashcode (Posted a comment)
  • -unavailable- added by prime (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 8 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 20 May 2013 09:00:21 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Fri 12 Apr 2013 10:49:57 AM UTCflashcodeStatusNeed Info=>Fixed
    Fri 22 Mar 2013 03:40:27 PM UTCflashcodeAttached File#27654=>Removed
    Fri 22 Mar 2013 03:21:19 PM UTCfancyboneAttached File-=>Added server_listfull.txt, #27653
      Attached File-=>Added bip_log.txt, #27654
      Attached File-=>Added weechat_connect.txt, #27655
    Mon 11 Mar 2013 07:27:32 AM UTCflashcodeStatusNone=>Need Info
      Assigned toNone=>flashcode

    Back to the top


    Powered by Savane 3.1-cleanup