bugWeeChat - Bugs: bug #38895, CTCP replies with "bold"...

 
 

bug #38895: CTCP replies with "bold" are misparsed

Submitted by:  Mantas M. <grawity>
Submitted on:  Sun 05 May 2013 04:09:57 PM UTC  
 
Category: irc pluginSeverity: 3 - Normal
Item Group: displayStatus: Fixed
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Open/Closed: Closed
Release: 0.4.0IRC nick: grawity

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 05 May 2013 04:09:57 PM UTC, original submission:

When a CTCP reply contains the "bold" format character, Weechat doesn't display the text as bold, but instead splits the reply at that point, also eating one character following the format char.

Example taken from Staticbox IRC network; the word "Suddenly" should have been displayed in bold by Weechat.

Mantas M. <grawity>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by flashcode (Updated the item)
  • -unavailable- added by grawity (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 20 May 2013 08:59:40 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Mon 06 May 2013 01:29:16 PM UTCflashcodeItem GroupNone=>display
      StatusNone=>Fixed
      Assigned toNone=>flashcode
      Release1.1-dev=>0.4.0

    Back to the top


    Powered by Savane 3.1-cleanup