bugWeeChat - Bugs: bug #38916, weechat occupy 100% of the cpu...

 
 

bug #38916: weechat occupy 100% of the cpu doing nothing

Submitted by:  None
Submitted on:  Tue 07 May 2013 03:20:30 AM UTC  
 
Category: script API pluginsSeverity: 3 - Normal
Item Group: otherStatus: Invalid
Privacy: PublicAssigned to: Sebastien Helleu <flashcode>
Originator Name: Francesco BerniOriginator Email: -unavailable-
Open/Closed: ClosedRelease: 0.3.8
IRC nick: kurojishi

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 08 May 2013 12:58:31 AM UTC, comment #3:

I had the same problem on Debian a year ago, it was caused by the leap second bug in the kernel. Strangely enough, only Ruby (and therefor the Weechat Ruby plugin) was affected.

Running
sudo date -s "`date`";
fixed it. I hope this helps

WakiMiko <wakimiko>
Tue 07 May 2013 06:32:15 AM UTC, comment #2:

Results of our chat on #weechat: ruby plugin causes the high CPU usage (version 1.9.1 used).

Temporary workaround, not load ruby plugin:

Please try to recompile WeeChat yourself and check if you still have problem.

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Tue 07 May 2013 05:43:26 AM UTC, comment #1:

Hi,

First, if you have 0.3.8, please first upgrade to 0.4.0 which is latest stable (if possible).

Please try to run WeeChat without plugins/scripts (weechat-curses -p) or without scripts (weechat-curses -s).

If you have always 100% CPU usage, please run gdb on WeeChat process to get a trace, so that I can see what WeeChat is doing.
Please look at user's guide for more info:
http://weechat.org/files/doc/devel/weechat_user.en.html#debug_running_weechat

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Tue 07 May 2013 03:20:30 AM UTC, original submission:

hi,
i run weechat on a remote server trought tmux, on a debian squeeze amd64 server(still not updated to wheezy), that weechat use nearly 100% of the cpu(from 50 to 100%).

checking with strace i notice that it call a lot of gettimeofday, but i'm not sure this is the reason of this unusual high cpu usage.

i tried to use a clean configuration so it's not a the fault of a plugin or a problem with my config.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by wakimiko (Posted a comment)
  • -unavailable- added by flashcode (Posted a comment)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 06 Oct 2013 07:42:51 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Sat 20 Jul 2013 05:55:03 AM UTCflashcodeStatusNeed Info=>Invalid
    Tue 07 May 2013 06:32:15 AM UTCflashcodeCategoryother=>script API plugins
    Tue 07 May 2013 05:43:26 AM UTCflashcodeCategoryNone=>other
      StatusNone=>Need Info
      Assigned toNone=>flashcode

    Back to the top


    Powered by Savane 3.1-cleanup