newsutil-vserver - News: [Announcement] util-vserver 0.27

 
 
Latest News
[Announcement] util-vserver 0.30 posted by ensc, Fri 02 Jul 2004 11:24:21 PM UTC - 0 replies
[Announcement] util-vserver 0.29 posted by ensc, Wed 11 Feb 2004 09:29:11 PM UTC - 0 replies
[Announcement] util-vserver 0.28 posted by ensc, Thu 29 Jan 2004 10:28:20 AM UTC - 0 replies
Temporary download location posted by ensc, Wed 14 Jan 2004 03:06:43 AM UTC - 0 replies
[Announcement] util-vserver 0.27 posted by ensc, Tue 30 Dec 2003 08:45:53 PM UTC - 0 replies
[Submit News]
[9 news in archive]

[Announcement] util-vserver 0.27

Item posted by Enrico Scholz <ensc> on Tue 30 Dec 2003 08:45:53 PM UTC.

Hello,

to finish some pending tasks of this year, I just released version 0.27
of util-vserver. It can be found at an interim place at

http://www.tu-chemnitz.de/~ensc/util-vserver/

When savannah's functionality is recovered entirely, it will be uploaded
to the known page at

https://savannah.nongnu.org/projects/util-vserver/

The main new feature is the a new 'vkill' command which is using new
features of vserver 1.1.6+. Changes in detail are:

- added new 'vkill' implementation which uses the syscall from
vserver 1.1.6+.

- BUGFIX: fixed typo in vc_get_version() wrapper which caused an
infinite recursive call of this function; this should not have
affected any userspace program

- BUGFIX: 'vps' accepts multiple arguments now (from Debian patch)

- vc_ctx_kill() was added

- chrootsafe() code was removed since such a functionality seems
to be impossible

- use 'vserver' instead of 'virtual_context' as the syscall name;
this will fix problems with architectures where the syscall is not
at #273.

- BUGFIX: fixed '--enable-apis' ./configure option; formerly, only
'ALL' or none were possible

- moved some old, unused programs/scripts into a seperate 'legacy'/
directory

- BUGFIX: /dev/pts will be mounted with correct options now

- added support for Slackware's init-method (thanks to Stephen
Pearce for the patch)

- API-CHANGE: followed kernel patches and renamed 'ctx_t' datatype
to 'xid_t'.

There are known problems with Red Hat rawhide's e2fsprogs package; see
[1] for details. Calling ./configure as

| ac_cv_header_ext2fs_ext2fs_h=no ./configure ...

and using good kernel headers should workaround it.

Else, I wish everybody a happy new year

Enrico

Footnotes:
[1] https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=112448

No messages in [Announcement] util-vserver 0.27

 

Back to the top


Powered by Savane 3.4