patchTiger UNIX security tool - Patches: patch #7859, Fix for the aide_run script to...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

patch #7859: Fix for the aide_run script to support AIDE 0.15.1 reports

Submitted by:  pyllyukko <pyllyukko>
Submitted on:  Sat 06 Oct 2012 08:26:57 PM UTC  
 
Category: Security testPriority: 5 - Normal
Status: NonePrivacy: Public
Assigned to: NoneOpen/Closed: Open

Sat 06 Oct 2012 08:26:57 PM UTC, original submission:

When I run Tiger on a system that has AIDE 0.15.1 installed, the aide_run script gives false negatives. It does not detect properly that AIDE has found differences on the file system.

Few regular expression modifications should fix this issue, see the attached patch.

Here are few lines from my AIDE report to demonstrate why it doesn't work:
"AIDE 0.15.1 found differences between database and filesystem!!" - version string after "AIDE" text
" Total number of files: ..." - 2 x space prefix

pyllyukko <pyllyukko>

 

Attached Files
file #26715:  tiger-aide.patch added by pyllyukko (1kB - text/x-patch - Aide patch)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by pyllyukko (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 06 Oct 2012 08:26:57 PM UTCpyllyukkoAttached File-=>Added tiger-aide.patch, #26715

    Back to the top


    Powered by Savane 3.1-cleanup