patchWeeChat - Patches: patch #8216, Require gettext 0.17

 
 

patch #8216: Require gettext 0.17

Submitted by:  Murilo Opsfelder Araujo <mopsfelder>
Submitted on:  Thu 24 Oct 2013 12:30:56 PM UTC  
 
Category: compilationPriority: 5 - Normal
Status: Wont DoPrivacy: Public
Assigned to: Sebastien Helleu <flashcode>Open/Closed: Closed
IRC nick: 

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 24 Oct 2013 07:04:38 PM UTC, comment #4:

The full error (problem with verbatim formatting):

      • error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version 0.17 but the autoconf macros are from gettext version 0.18
Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Thu 24 Oct 2013 07:03:52 PM UTC, comment #3:

I tried, but I got this error, and I have no idea how to fix that:

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Thu 24 Oct 2013 06:42:41 PM UTC, comment #2:

Hi Sebastien,

AM_GNU_GETTEXT_VERSION checks for a minimum version. So having it to check for 0.17 will pass on systems with gettext >= 0.17.

But I can live with the fact autotools will be removed from weechat.

You may close this.

Murilo Opsfelder Araujo <mopsfelder>
Thu 24 Oct 2013 01:41:29 PM UTC, comment #1:

Hi,

I'm not able to compile with gettext 0.17 since it's not available on my Debian (I have only 0.18).

Anyway, you should NOT compile with autotools unless you have a good reason to do that (autotools may be removed from WeeChat in future).
Cmake is the preferred way to compile weechat, and it should work with any version of gettext.

If you really can't use cmake (which is better and faster than autotools), then I guess you'll have to patch the configure.ac manually.
Or if you have a better solution that would work on a machine with only gettext 0.18, please tell me :)

Sebastien Helleu <flashcode>
Project AdministratorIn charge of this item.
Thu 24 Oct 2013 12:30:56 PM UTC, original submission:

RHEL 6 has gettext 0.17 and it is able to build weechat 0.4.2 using this version of gettext. There is no real need for 0.18 as introduced by commit a3cc9bbe7e5dc868223f87471d1b569506341c86.

Murilo Opsfelder Araujo <mopsfelder>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by flashcode (Posted a comment)
  • -unavailable- added by mopsfelder (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 09 Feb 2014 09:53:25 AM UTCflashcodeOpen/ClosedOpen=>Closed
    Thu 24 Oct 2013 01:41:29 PM UTCflashcodeStatusNone=>Wont Do
      Assigned toNone=>flashcode
    Thu 24 Oct 2013 12:30:56 PM UTCmopsfelderAttached File-=>Added 0001-Require-gettext-0.17.txt, #29458

    Back to the top


    Powered by Savane 3.1-cleanup