patchAVR Downloader/UploaDEr - Patches: patch #8219, Fix boot_start for xmega devices...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

patch #8219: Fix boot_start for xmega devices on jtagmkII

Submitted by:  Tom Carney <tcarney>
Submitted on:  Fri 25 Oct 2013 10:30:20 PM UTC  
 
Category: NonePriority: 5 - Normal
Status: NonePrivacy: Public
Assigned to: NoneOpen/Closed: Open

Fri 25 Oct 2013 10:30:20 PM UTC, original submission:

Writing to the boot section on xmega devices (using avrdude 6.0.1 and jtagmkII) fails due to improperly set boot_start. This patch fixes the initialization of boot_start as per jtag3.c. (Due to the duplicated comment from a few lines above, this seems to be a simple merge error.) Tested on xmega192d3 and jtagmkII (fw 6.17 and 7.36)

Relates to solution from bug #28744

Tom Carney <tcarney>

 

Attached Files
file #29469:  jtagmkII.c.patch added by tcarney (530B - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by tcarney (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follows 1 latest change.

    Date Changed By Updated Field Previous Value => Replaced By
    Fri 25 Oct 2013 10:30:20 PM UTCtcarneyAttached File-=>Added jtagmkII.c.patch, #29469

    Back to the top


    Powered by Savane 3.1-cleanup