helpThe OpenVortex Project - Support: sr #102953, Vortex 8830 playback problems

 
 

sr #102953: Vortex 8830 playback problems

Submitted by:  None
Submitted on:  Mon 29 Mar 2004 12:19:41 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 1 - WishStatus: None
Privacy: PublicAssigned to: None
Originator Email: -unavailable-Open/Closed: Open
Operating System: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Thu 08 Jul 2004 09:33:02 AM UTC, comment #15:

Sample rate conversion with
27-point interpolation

http://www.3dsoundsurge.com/reviews/ sq2500preview/images/2500datasheet.pdf

Anonymous
Sun 13 Jun 2004 02:40:07 AM UTC, comment #14:

export PA_ALSA_PERIODSIZE=1024
audacity

This will allow audacity to use your specificed period size

Anonymous
Wed 02 Jun 2004 02:23:27 PM UTC, comment #13:

most likely audacity cannot find the required period size for au88x0.

/* Find an acceptable number of periods */
numPeriods = (latency *sampleRate) / framesPerBuffer + 1;
numPeriods = MAX( numPeriods, 2 ); /* Should be at least 2 periods I think? */
ENSURE( snd_pcm_hw_params_set_periods_near( pcm, hwParams, &numPeriods, NULL ), paUnanticipatedHostError );

http://cvs.sourceforge.net/viewcvs.py/checkout/audacity/lib-src/portaudio-v19/pa_linux_alsa/pa_linux_alsa.c?rev=1.1.2.1

Anonymous
Tue 01 Jun 2004 03:55:03 AM UTC, comment #12:

Please update your au88x0 to alsa-driver-1.0.5, there is a known bug (sound playing fast) and missing VIA workaround in alsa-driver-1.0.4

For those are running kernel 2.6.x, you should upgrade your kernel to 2.6.7-rc1 or later.

Anonymous
Sun 30 May 2004 02:26:48 PM UTC, comment #11:

Audacity version 1.2.1

./configure --with-portaudio=v19

http://lists.gnu.org/archive/html/openvortex-dev/2004-05/msg00002.html

Got segmentation fault message when pressing the record button

Do we need to define correct min max channels for the capture stream in snd_vortex_pcm_open() ?

static snd_pcm_hardware_t snd_vortex_capture_hw_adb

.channels_min = 1,
.channels_max = 2,

Anonymous
Tue 25 May 2004 02:01:45 AM UTC, comment #10:

snd_ac97_try_volume_mix() use bit 4 (headphone support) of ac97 register 0 to create headphone volume control. this is not present in STAC9708. Therefore the headphone volume control will not create for STAC9708 and cannot be rename to Sigmatel Surround Playback in ac97_patch.c
http://cvs.sourceforge.net/viewcvs.py/alsa/alsa-kernel/pci/ac97/ac97_codec.c?r1=1.132&r2=1.133

Anonymous
Mon 24 May 2004 05:31:42 PM UTC, comment #9:

Using the CVS tree from alsa

http://www.alsa-project.org/download.php3

./cvscompile --with-cards=au8830 --with-sequencer=yes

It seem that the SDAC Mixer Volume control ( AC97 reg 04 ) of STAC9708 disappear from alsamixer and only SDAC Master Volume control (AC97 reg 38 ) remain.

Anonymous
Mon 24 May 2004 04:46:47 PM UTC, comment #8:

It seem that the alsa team change some code for STAC9708

http://cvs.sourceforge.net/viewcvs.py/alsa/alsa-kernel/pci/ac97/ac97_codec.c?r1=1.132&r2=1.133

http://cvs.sourceforge.net/viewcvs.py/alsa/alsa-kernel/pci/ac97/ac97_patch.c?r1=1.49&r2=1.50

Anonymous
Mon 24 May 2004 08:00:51 AM UTC, comment #7:

https://bugtrack.alsa-project.org/alsa-bug/bug_view_page.php?bug_id=0000299

<quote>CDROM,line-in,video,auxiliar,etc audio won't be hearable through the "headpones" output, since the codec is not capable to do so, and another kind of workaround is needed for that.</quote>

All AC97 codec can mix analog input (CD , Mic, Line in, ... ) to Master Output.

You will not get any sound if the volume (gain) of the 10 band equalizer are negative with equalizer enabled.

Anonymous
Mon 24 May 2004 07:44:20 AM UTC, comment #6:

Hardware mixing

https://bugtrack.alsa-project.org/alsa-bug/bug_view_page.php?bug_id=0000216

<i>playing an mp3 over XMMS/oss emulation, and then taking GAIM set to automatic mode, and rapidly forcing multiple AIM sounds to the sound card.</i>

I think XMMS/oss emulation is block mode which do not allow other application to play multiple sound.

You need to use XMMS alsa plugin if you want other application play sound at the same time

Anonymous
Fri 09 Apr 2004 02:42:39 AM UTC, comment #5:

The current au88x0 driver relies on snd_vortex_pcm_hw_params to allocate dynamic routes for mono, stereo, quad, wt and a3d.

But the dynamic routes are not clean up properly.

You better use mpg123 alsa output instead of mpg123 oss output and oss emulation.

Anonymous
Wed 07 Apr 2004 01:16:46 AM UTC, comment #4:

The adb routing table is not initialized for au88x0 in alsa-1.0.4

http://mail.gnu.org/archive/html/openvortex-dev/2004-03/msg00032.html

VIA workaround patch

http://mail.gnu.org/archive/html/openvortex-dev/2004-03/msg00033.html

Front and Rear channels swap in Surround40

support #102939

Anonymous
Tue 06 Apr 2004 10:45:15 PM UTC, comment #3:

I have the same problem. I'm running Slack 9.1 with 2.4.25 and alsa 1.0.4. I've noticed that if I run mpg123 with oss output right after my linux have booted, the sound is too fast, but if I run mpg123 with alsa output everything goes normal and I can use oss output after that. I have same chipset NForce 2.

Anonymous
Sun 04 Apr 2004 08:44:26 AM UTC, comment #2:

rmmod snd-page-alloc module.

http://www.mail-archive.com/alsa-devel@lists.sourceforge.net/msg12265.html

Anonymous
Tue 30 Mar 2004 08:19:36 AM UTC, comment #1:

./cvscompile --with-cards=au8830

.
.
.
make install
/etc/init.d/alsasound start
Starting sound driver: snd-au8830 /lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: unresolved symbol snd_dma_alloc_pages_R2cbfa9e2
/lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: unresolved symbol snd_dma_set_reserved_R77de065d
/lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: unresolved symbol snd_dma_free_reserved_Rfe02b257
/lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: unresolved symbol snd_dma_free_pages_Rdbbb3d95
/lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: unresolved symbol snd_dma_get_reserved_R0d073398
/lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: insmod /lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o failed
/lib/modules/2.4.22-1.2174.nptl/kernel/sound/acore/snd-pcm.o: insmod snd-au8830 failed

Anonymous
Mon 29 Mar 2004 12:19:41 PM UTC, original submission:

About 50% of the times I try to play something, regardless of the player i use, the sound is either way too fast or with a lot of noise... I'm using Slack9.1, kernel 2.4.22, latest CVS version of alsa-drivers... on a Nvidia NFORCE2 MB.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

No Changes Have Been Made to This Item

Back to the top


Powered by Savane 3.1-cleanup