helpdavfs2 - Support: sr #108120, Configure issue with davfs2-1.4.7

 
 

sr #108120: Configure issue with davfs2-1.4.7

Submitted by:  Andre <uenz>
Submitted on:  Sun 26 Aug 2012 03:44:33 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: Done
Privacy: PublicAssigned to: Werner Baumann <wbaumann>
Open/Closed: ClosedOperating System: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 06 Sep 2012 11:00:32 AM UTC, comment #5:

You can get rid of the mtab entry by a small change that prevents davfs2 from writing an entry into mtab at all.

In file mount_davfs.c in function write_mtab_entry just insert a return command at the very beginning. Like this:

/* Adds an entry to _PATH_MOUNTED for the mounted file system.
If this fails a warning will be printed, but this will not stop mounting. */
static void
write_mtab_entry(const dav_args *args)
{
return;
struct mntent mntent;
mntent.mnt_fsname = url;
...

Werner Baumann <wbaumann>
Project AdministratorIn charge of this item.
Mon 03 Sep 2012 04:44:22 PM UTC, comment #4:

Tried with success to copy the 1.4.7 src folder in the 1.4.6 "environment" and build davfs. So it seems to be the auto-tools.
(on NAS is installed autoconf - 2.69-1; automake - 1.12-1)

Regarding the unmount issue the manual remove of the entry in /etc/mtab did the trick! If Optware is installed on a QNAP NAS the complete system (at least every ssh shell) seems to run in a chroot environment. So i think each mount / unmount is in a chroot environment.

Thanks
uenz

Andre <uenz>
Mon 03 Sep 2012 07:03:40 AM UTC, comment #3:

The configure script in version 1.4.7 is indeed created by newer versions of the Gnu auto-tools. But I'm surprised that this conflicts with gawk.

The easiest way to build 1.4.7 with the build-tools from 1.4.6:
Start with version 1.4.6 and replace all .h and .c files in the src directory by the files from 1.4.7, but no other files. So you get a version 1.4.6 but with the bug-fixes from 1.4.7 included.

This will fix some bugs in 1.4.6 but will not help with your problem. The entry in mtab is written by mount.davfs but it is removed by the system's umount program. There is some problem with the umount command the chroot environment. I have no clue what the problem is. You call umount form the chroot environment?

When the mtab entry is not removed but the file system is unmounted (no more entry in /proc/mounts) and the pid-file in /var/run/mount.davfs is removed it should not be necassary to restart the device. Rmoving the entry from mtab with some editor (and root privileges) should do the job.

Cheers
Werner

Werner Baumann <wbaumann>
Project AdministratorIn charge of this item.
Sun 02 Sep 2012 03:25:29 PM UTC, comment #2:

Its actually a QNAP device. Version 1.4.6 builds (with "chroot patch": http://savannah.nongnu.org/support/?107637) and works, but version 1.4.7 does not build. Tried to merge the source changes to my 1.4.6 folder but without luck. The "build environment" seems to have changed in 1.4.7.
I wanted to try version 1.4.7 because sometimes i have issues to unmount the davfs share. The unmount command succeedes, but the device stays in the mtab and is not remountable (restart of device necessary).

Andre <uenz>
Sun 02 Sep 2012 02:55:17 PM UTC, comment #1:

I have no access to a Synology NAS and can't reproduce the problem.

It seems that version 1.4.6 builds successfully on this device. Please try this version of davfs2. If 1.4.6 works, but 1.4.7 does not work I could check which changes might be the reason (but the build system did not change much in 1.4.7).

Cheers
Werner

Werner Baumann <wbaumann>
Project AdministratorIn charge of this item.
Sun 26 Aug 2012 03:44:33 PM UTC, original submission:

Hi,
i tried to compile davfs2 according to https://savannah.nongnu.org/support/?108022. But i'm not able to configure davfs2.
It seems to run ok until
configure: creating ./config.status
config.status: creating Makefile
then i get these errors:
gawk: ./confXDFFoe/subs.awk:2: S["/; s/!.*/"]=am__EXEEXT_FALSE!%!_!# ""
gawk: ./confXDFFoe/subs.awk:2: ^ syntax error
gawk: ./confXDFFoe/subs.awk:3: S["/; s/!.*/"]=am__EXEEXT_FALSE!%!_!# ""
gawk: ./confXDFFoe/subs.awk:3: ^ syntax error
gawk: ./confXDFFoe/subs.awk:4: S["/; s/!.*/"]=am__EXEEXT_TRUE!#%!_!# "#"
gawk: ./confXDFFoe/subs.awk:4: ^ syntax error
gawk: ./confXDFFoe/subs.awk:4: S["/; s/!.*/"]=LTLIBOBJS!%!_!# ""
gawk: ./confXDFFoe/subs.awk:4: ^ syntax error
A full log is available at http://pastebin.com/etqPrNF3

Thans for any hints
uenz

Andre <uenz>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by wbaumann (Posted a comment)
  • -unavailable- added by uenz (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 20 Apr 2014 07:17:01 PM UTCwbaumannStatusIn Progress=>Done
      Open/ClosedOpen=>Closed
    Sun 02 Sep 2012 02:55:17 PM UTCwbaumannStatusNone=>In Progress
      Assigned toNone=>wbaumann

    Back to the top


    Powered by Savane 3.1-cleanup