helpdavfs2 - Support: sr #108416, problems mounting a Sharepoint...

 
 

sr #108416: problems mounting a Sharepoint directory

Submitted by:  None
Submitted on:  Fri Oct 18 15:04:19 2013  
 
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: In Progress
Privacy: PublicAssigned to: Werner Baumann <wbaumann>
Originator Email: -unavailable-Open/Closed: Open
Operating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri May 9 15:34:07 2014, comment #4:

I don't know whether this will be useful to the original poster, but we initially had a bit of trouble mounting Sharepoint 2010 with NTLM authentication. Basic authentication worked fine. I'm posting my notes just in case they will be useful to others.

When I changed Sharepoint authentication from Basic to NTLM (the same applies to Kerberos), I got an error:

"Could not authenticate to server: ignored NTLM challenge, GSSAPI authentication error: Unspecified GSS failure. Minor
code may provide more information: Credentials cache file '/tmp/krb5cc_0' not found"

I googled and found the explanation at http://savannah.nongnu.org/support/?108061 that indicated that the error happens when mount.davfs is using GNUTLS instead of OpenSSL.

Rebuilding davfs with OpenSSL resolved the problem.

Alex Jodidio <ajodidio>
Thu Nov 7 12:29:11 2013, comment #3:

SP admins found no clue from the logs before or after the occuring of the SPRequestGUID I posted them (from the latest request I did). So I'm quite clue- and hopeless now. I don't think we will get this working :'(

Is someone here with a working connection to a sharepoint-farm?

Anonymous
Thu Nov 7 11:16:56 2013, comment #2:

At first sorry for the delay - holidays have been in between ...

- I already set "allow_cookie 1", but with no success :(
- As far as I understand e. g. http://msdn.microsoft.com/en-us/library/dd908737(v=office.12).aspx the SPRequestGUID is for diagnostic purposes only. (It may help identify the requiest I do for the Sharepoint administrators)

So we still have no clue why this doesn't work. Maybe there is some weird configuration on SP side, but I can't exert influence on that much. (I will try though)

Will keep you updated.

Anonymous
Thu Oct 24 18:14:37 2013, comment #1:

Yes, the fisrst step works. it is authentication with the proxy. So, the proxy seems not to be aproblem.

But authentication with the server fails. davfs2 tries it three times but each time it fails.
line 32 : HTTP/1.1 401 Unauthorized
line 71 : HTTP/1.1 401 Unauthorized
line 101: HTTP/1.1 401 Unauthorized

At the moment I see three possible reasons:

1) Cookies:
The server sends a cookie-header. By default davfs2 ignores cookies. But with this server farm the cookie might be necessary to make sure that all requests are directed to the same server.
You can set option 'allow_cookie 1'. davfs2 will then include a cookie-header. Maybe this will help.

2) SPRequestGuid:
The server also sends header SPRequestGuid. I don't know what this header is for. If davfs2 is required to set this header in the requests too, this would require some extensions to the source-code of davfs2.

3) NTLM:
Your version of the Neon library is able to handle NTLM-authentication. But there might be subtle differences. I assume your stand-alone server uses NTLM too (you may check). So this is probably not the reason.

Werner

Werner Baumann <wbaumann>
Project AdministratorIn charge of this item.
Fri Oct 18 15:04:19 2013, original submission:

Hello,

I have problems with mounting a Sharepoint 2010 directory (it's a sharepoint farm, no problems with a single SP2010 host).
Attached you will find some of our syslog file. I only obfuscated some variables (username, URL, PW).

Obviously in the first step the authentication works, but it doesn't work when it comes to the last step. At least that one is different to when connection works (to another, single-host SP-Server).
I tried with and without proxy (firewall team opened the connection), no success :(

Any idea what could get wrong here?

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

Attached Files
file #29406:  syslog.txt added by None (14kB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by ajodidio (Posted a comment)
  • -unavailable- added by wbaumann (Posted a comment)
  • -unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu Oct 24 18:14:37 2013wbaumannStatusNone=>In Progress
      Assigned toNone=>wbaumann
    Fri Oct 18 15:04:19 2013NoneAttached File-=>Added syslog.txt, #29406

    Back to the top


    Powered by Savane 3.1-cleanup1