helpSpamAssassin Milter Plugin - Support: sr #104478, ./configure file cannot find...

 
 

sr #104478: ./configure file cannot find libmilter

Submitted by:  None
Submitted on:  Tue 19 Jul 2005 09:31:27 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: None
Privacy: PublicAssigned to: Dan Nelson <dnelson>
Originator Email: -unavailable-Open/Closed: Open
Operating System: GNU/Linux

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Fri 05 Aug 2005 08:13:11 PM UTC, comment #8:

k, figured it out ......

copied the libmilter directory I created from sendmail source to the /usr/lib directory (ie /usr/lib/libmilter), then copied the include/libmilter directory into /usr/include directory (ie /usr/include/libmilter).

All works!!!

___
checking for mi_stop in -lmilter... yes
checking libmilter/mfapi.h usability... yes
checking libmilter/mfapi.h presence... yes
checking for libmilter/mfapi.h... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating contrib/spamass-milter.spec
config.status: creating spamass-milter.1
config.status: creating config.h
config.status: executing depfiles commands

Anonymous
Thu 04 Aug 2005 08:10:29 AM UTC, comment #7:

Here is the path to

/var/files/rpm/other_files/sendmail-8.13.1/include/libmilter/mfapi.h

Anonymous
Thu 04 Aug 2005 08:09:35 AM UTC, comment #6:

ooohhhh boy...

now get the following;

checking for mi_stop in -lmilter... yes
checking libmilter/mfapi.h usability... no
checking libmilter/mfapi.h presence... no
checking for libmilter/mfapi.h... no
configure: error: Please install mfapi.h from the sendmail distribution

Anonymous
Wed 03 Aug 2005 08:37:35 PM UTC, comment #5:

Tell configure about that path by setting LDFLAGS="-L/var/files/rpm/other_files/sendmail-8.13.1/obj.Linux.2.6.8.1-12mdksmp.i686/libmilter/"
before running configure, or as you run it:

LDFLAGS="-L/var/blah/blah" ./configure

Dan Nelson <dnelson>
Project AdministratorIn charge of this item.
Wed 03 Aug 2005 07:51:37 PM UTC, comment #4:

Hi Dan,

Grabbed the source and created the libmilter.a file. Hereis the path...
/var/files/rpm/other_files/sendmail-8.13.1/obj.Linux.2.6.8.1-12mdksmp.i686/libmilter/libmilter.a

Here is the config.log info;
configure:7084: checking for mi_stop in -lmilter
configure:7114: g++ -o conftest -g -O2 -Wall -fno-default-inline -fno-inline -pthread conftest.cc -lmilter >&5
/usr/bin/ld: cannot find -lmilter
collect2: ld returned 1 exit status
configure:7120: $? = 1
configure: failed program was:
| /* confdefs.h. */

Anonymous
Wed 20 Jul 2005 03:03:59 PM UTC, comment #3:

Thanks, the Mandrake installation installs the milter support but does not install the library files and I can't seem to find any source packages. I am trying to source these.....

Anonymous
Tue 19 Jul 2005 09:56:01 PM UTC, comment #2:

Sorry; the file to check is config.log, not configure.log.

Dan Nelson <dnelson>
Project AdministratorIn charge of this item.
Tue 19 Jul 2005 09:54:13 PM UTC, comment #1:

It's possible sendmail was built with milter support but Mandrake didn't install the milter library itself. Check and see if you have a libmilter.a file anywhere on the system, and if not, install it (hopefully mandrake provided a sendmail-milter rpm or whatever format it uses).

If you do have a libmilter file, please give me the location of the file on your system and paste in the part of configure.log just after "checking for mi_stop in -lmilter...". There should be a gcc command and a link error.

Dan Nelson <dnelson>
Project AdministratorIn charge of this item.
Tue 19 Jul 2005 09:31:27 PM UTC, original submission:

I am trying to install the spamass-milter on Mandrake 10.1 with sendmail 8.13 which has Milter support;
sendmail -d0 < /dev/null | grep MILTER
Compiled with: DNSMAP LDAPMAP LOG MAP_REGEX MATCHGECOS MILTER MIME7TO8

The config file keeps on stopping at the following error;
checking for mi_stop in -lmilter... no
checking for library containing strlcpy... no
checking for mi_stop in -lmilter... no
configure: error: Cannot find libmilter

How do I get around this to continue the installation?

Thanks

Gordon

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

Follow 2 latest changes.

Date Changed By Updated Field Previous Value => Replaced By
Tue 19 Jul 2005 09:54:13 PM UTCdnelsonAssigned toNone=>dnelson
Tue 19 Jul 2005 09:31:27 PM UTCNoneCarbon-Copy-=>Added gordon --AT-- itnt --DOT-- co --DOT-- za

Back to the top


Powered by Savane 3.1-cleanup