helpSpamAssassin Milter Plugin - Support: sr #106293, spamass-milter 0.3.1 and solaris...

 
 

sr #106293: spamass-milter 0.3.1 and solaris 10, uses 100% of CPU

Submitted by:  Cheryl Southard <cld>
Submitted on:  Fri 07 Mar 2008 06:29:07 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenOperating System: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

(Jump to the original submission Jump to the original submission)

Mon 16 Jun 2008 03:36:41 PM UTC, comment #7:

Hi Dan,

Any ideas on what's going wrong? Spamass-milter has gotten stuck 8 times in the last 5 weeks, so the problem definitely still exists.

Thanks,
Cheryl

Cheryl Southard <cld>
Wed 07 May 2008 04:32:33 PM UTC, comment #6:

Hi Dan,

Here's a stack trace for a spamass-milter that's stuck. Note that it's not the "main" spamass-milter that is getting stuck; It's a child of the main spamass-milter process.

mailserver# pstack 29702/26935
29702: /etc/mail/sbin/spamass-milter -p /var/run/spamass.sock -f -r 10 -u spa
ff143720 _ZN9__gnu_cxx18__exchange_and_addEPVii (42ca0, ffffffff, 1, 3e, 0, 0) + 20
ff12862c _ZNSs9_M_mutateEjjj (42b80, 0, 0, 42c98, 0, 0) + 1c0
ff128df4 _ZNSs12_M_leak_hardEv (42b80, 0, 0, 0, 0, 0) + 58
ff128eb0 _ZNSsixEj (42b80, 0, 0, 0, 0, 0) + 18
000151d0 _ZN12SpamAssassin10local_userEv (42b80, 1, 95f8c, 14048, fef6a2b4, fef729f8) + 10
00015c74 _ZN12SpamAssassin7ConnectEv (42b50, 1a9b8, cc, 1, 40, 0) + 5ac
00016a78 Z11mlfi_headerP8smfi_strPcS1 (33ec0, 42da0, 42da9, fe6fbe38, 8, 42da9) + 38
ff3743d8 st_header (0, 16a40, ffffffff, ff38a6d0, ff38a000, fe6fbed0) + 5c
ff373a5c mi_engine (33ec0, 7, ff38a000, 42da0, 7, 16664) + 2d0
ff375dd4 mi_handle_session (33ec0, 33ec0, 14264, 0, ff38a000, ffffffff) + 54
ff375418 mi_thread_handle_wrapper (33ec0, fe6fc000, 0, 0, ff375414, 0) + 4
fef408e8 _lwp_start (0, 0, 0, 0, 0, 0)

Cheryl Southard <cld>
Tue 29 Apr 2008 08:05:42 PM UTC, comment #5:

"prstat -L" calls it the LWPID, and it's tacked on after the process name in the rightmost column. Without -L, the number after the slash is just the total thread count for the process.

Dan Nelson <dnelson>
Project Administrator
Tue 29 Apr 2008 06:58:31 PM UTC, comment #4:

Hi Dan,

Thanks for a reply. Sure, I can run those commands the next time spamass-milter gets stuck, but it's been running really well for me lately.

One thing... "prstat -L" doesn't tell me a "thread number" as far as I can tell. But I can run those commands by using the pid.

Cheryl Southard <cld>
Tue 29 Apr 2008 06:42:43 PM UTC, comment #3:

Can you run "prstat -L" to determine which thread number is consuming the CPU, and then run "pstack" on the process to get a stack trace for that thread? dtrace would probably return better information, but I don't know how to use it yet :)

Dan Nelson <dnelson>
Project Administrator
Tue 29 Apr 2008 03:41:15 PM UTC, comment #2:

Hi Anonymous,

No, we never found a solution for this problem. Usually, it'll occurs in a cluster of 4 times in a week, then not at all for a month.

Cheryl Southard <cld>
Tue 29 Apr 2008 03:18:51 PM UTC, comment #1:

Did anyone get a solution to this? Or is it no longer a problem? I'm about to install this exact situation on my T1000 sparc running Solaris 10.

Anonymous
Fri 07 Mar 2008 06:29:07 PM UTC, original submission:

Hi Folks,

I am running spamass-milter 0.3.1 with sendmail 8.14.1 and 3.2.4.
I am doing this on a Solaris 10 computer.

For the most part, spamass-milter works like a champ. I'm using these flags:
/etc/mail/sbin/spamass-milter -p /var/run/spamass.sock -f -r 10 -u spamass-milter-default

So it automatically rejects e-mails with scores greater than 10.

My problem is that every few days, spamass-milter gets stuck. When it is stuck, it is always a child spamass-milter (so the main
spamass-milter continues to work). From "truss -p <pid>, it apperas that spamass-milter is doing nothing. From the log file, I see the following errors:

Milter (spamassassi): timeout before data read, where=body
Milter (spamassassin): to error state

And although spamass-milter is "stuck", the e-mail gets through to our user without delay, though clearly it has not been processed by spamassassin because it contains no X-Spam-Status headers.

We sometimes get the above Milter error messages and spamass-milter DOESN'T get stuck.

Does anyone know how I can figure out what's going on and fix this problem? Once spamass-milter hits 100% CPU usage, my e-mail server gets really slow and my users get grumpy.

Cheryl Southard <cld>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by dnelson (Posted a comment)
  • -unavailable- added by cld (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup