bugAVR Downloader/UploaDEr - Bugs: bug #30753, bsd programmer causes PCI parport...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #30753: bsd programmer causes PCI parport to bring interrupt storm to Linux

Submitted by:  Guan Xin <cppgx>
Submitted on:  Wed 11 Aug 2010 10:56:18 PM UTC  
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Wont Fix Privacy:  Public
Assigned to:  Joerg Wunsch <joerg_wunsch> Originator Name:  Xin Guan
Open/Closed:  Closed Release:  None
Programmer hardware:  Device type: 

Thu 12 Aug 2010 04:20:56 AM UTC, comment #1: 

I'm sorry, but there is not much AVRDUDE could do about that.
We cannot modify the hardware that is already being used in
the field.  In your situation, simply pick a different
parport programming adapter.  Note that using ACK for MISO
input appears to be a very popular choice, if you look at
the other programmer definitions (including the old Kanda
STK200).

Also, if that problem only exists for one parport adapter
driver in your OS, this rather smells like a driver bug to
me then.  It is arguable that, when opening /dev/parportN,
the driver could/should know that it does not make sense to
use interrupts at all, so they ought to be turned off
completely.  At the very least, the interrupt storm should
terminate by the time AVRDUDE stops using the port.

Joerg Wunsch <joerg_wunsch>
Project AdministratorIn charge of this item.
Wed 11 Aug 2010 10:56:18 PM UTC, original submission:  

bsd programmer uses ACK line for input. With my "NetMos Technology PCI 1 port parallel adapter (rev 01)", this will generate infinit interrupts during and after programming.

On Linux 2.6.34.* I can see "hi" taking a good portion of CPU time in "top". On Linux 2.6.35.*, "hi" takes 0.0% CPU time. However, in both cases the system is slowed down by more than 70%. The same problem does not occur when I use the traditional ISA parport on the same computer (with the bsd programmer).

By changing MISO to line 12 (paper out), the problem is solved.

Guan Xin <cppgx>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by joerg_wunsch (Posted a comment)
  • -email is unavailable- added by cppgx (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2010-08-12 joerg_wunsch StatusNone => Wont Fix
        Assigned toNone => joerg_wunsch
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5