bugGPSD - Bugs: bug #52635, gpsd: gpsmon u-blox time reporting...

 
 

bug #52635: gpsd: gpsmon u-blox time reporting incorrect

Submitted by:  Bernd Zeimetz <bzed>
Submitted on:  Mon 11 Dec 2017 12:03:27 AM UTC  
 
Category:  None Severity:  4 - Important
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 11 Dec 2017 12:03:27 AM UTC, original submission:

Forwarded from http://bugs.debian.org/884055

When using the gpsmon tool with a u-blox GPS module, the time is
reported incorrectly in the NAV_SOL box. This is because of a series of
arithmetic errors in the code (times are reported in milliseconds, but
the math seems to assume they are in centiseconds).

This patch corrects the error and produces accurate times. Tested with
both a NEO-M8N connected over USB and a NEO-6N module on a Raspberry Pi.

Patch is here: https://bugs.debian.org/cgi-bin/bugreport.cgi?att=1;bug=884055;filename=patch;msg=5

Bernd Zeimetz <bzed>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bzed
  • -email is unavailable- added by bzed (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-12-11 bzed Carbon-Copy- => Added -email is unavailable-

    Back to the top


    Powered by Savane 3.3