buglwIP - A Lightweight TCP/IP stack - Bugs: bug #61449, Incoherent tot_len field in...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #61449: Incoherent tot_len field in etharp_update_arp_entry output

Submitted by:  Jean-Chriostophe MATHAE <jchmathae>
Submitted on:  Tue 09 Nov 2021 10:44:22 AM UTC
 
Category:  ARP Severity:  3 - Normal
Item Group:  Faulty Behaviour Status:  Invalid
Privacy:  Public Assigned to:  goldsimon
Open/Closed:  Closed Planned Release:  None
lwIP version:  * 2.1.1
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Fri 12 Nov 2021 09:19:02 PM UTC, comment #2: 

The function 'etharp_update_arp_entry' just sends the first pbuf enqueued for sending (but pendign because the ETH addr is not yet known).

As such, this would be a bug in how the first pbuf is sent, not a bug in our ARP code.

Obviously, I can't reproduce this. Please investigate your code and report any real issues you find.

Simon Goldschmidt <goldsimon>
Project Administrator
Wed 10 Nov 2021 08:13:28 AM UTC, comment #1: 

Some context:
  * lwIP used in mainloop (NO_SYS == 1) mode
  * problem only appears once on first ARP message
  * on call to pbuf_free with this pbuf an error will be raised

If this error is ignored everything will work after.

Jean-Chriostophe MATHAE <jchmathae>
Tue 09 Nov 2021 10:44:22 AM UTC, original submission:  

Hello,

In lwIP version 2.1.2, in a call to netif_linkoutput() from etharp_update_arp_entry()/ethernet_output() the 'pbuf' structure passed as second argument has an incoherence in its 'tot_len' field: it has a value of 54, its 'len' field has a value of 42 and the 'next->len' field has a value of 50 ('next->tot_len' if also 50).

Jean-Chriostophe MATHAE <jchmathae>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by yarrick (Updated the item)
  • -email is unavailable- added by goldsimon (Posted a comment)
  • -email is unavailable- added by jchmathae (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-11-13 yarrick Open/ClosedOpen => Closed
    2021-11-12 goldsimon StatusNone => Invalid
        Assigned toNone => goldsimon

    Back to the top


    Powered by Savane 3.9