helpLinterna Mágica - Support: sr #107708, Reassigned to another tracker...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

sr #107708: Reassigned to another tracker [was: The Onion]

Submitted by:  None
Submitted on:  Mon 30 May 2011 11:07:36 AM UTC  
 
Category:  Support for new website Priority:  5 - Normal
Severity:  1 - Wish Status:  Done
Privacy:  Public Assigned to:  Ivaylo Valkov <valkov>
Originator Email:  -email is unavailable- Open/Closed:  Closed
Release:  0.0.9-6 Operating System:  GNU/Linux

Sun 10 Jun 2012 06:40:30 PM UTC, comment #5:

THIS ITEM WAS REASSIGNED TO BUG #36629


Please, do not post any new comments to this item.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Mon 01 Aug 2011 07:07:23 PM UTC, comment #4:

The code in trunk now can switch the clips on the front page properly. Will not port it to 0.0.9, because 0.0.10 will be released soon.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Wed 15 Jun 2011 10:31:23 AM UTC, comment #3:

It seems stable enough for me. It is almost ready to be marked as Done. The code in 0.0.9-7 has some features stripped, because they were too buggy to be fixed in time.

The code in trunk is able to switch video clips at the front page, but needs more work to clear few more glitches.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Mon 13 Jun 2011 08:28:45 AM UTC, comment #2:

I have commited working code in trunk. Backported it to branch 0.0.9, but it has some issues. Will be available in 0.0.9-7, which will be released (probably) at 14th of June.

Backported because 0.0.10 i still with unclear release date.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Wed 01 Jun 2011 08:10:30 AM UTC, comment #1:

I was able to find out how to get video links. A XHR request with video clip ID returns JSON object with video URL and other data. It is at the same domain, so it should be possible to use it in Linterna Mágica.

The URL format is :
http://www.theonion.com/ajax/onn/embed/<ID>.json

Each video is placed in <iframe> tag. It seems there is HTML5 version for Apple products. It might be triggered by user-agent sniffing. It is not working in Epiphany, which uses WebKit and has Safari strings in its user-agent.

When working code is available in trunk I will post new comment here.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Mon 30 May 2011 11:07:36 AM UTC, original submission:

THIS ITEM WAS REASSIGNED TO BUG #36629
Videos aren't playing on The Onion dot com.

Anonymous

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by valkov (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-06-10 valkov Reassign ItemLinterna Mágica, sr #107708 => Linterna Mágica, bug #36629
    2011-08-01 valkov StatusWorks For Me => Done
        Open/ClosedOpen => Closed
    2011-06-15 valkov StatusReady For Test => Works For Me
    2011-06-13 valkov StatusIn Progress => Ready For Test
    2011-06-01 valkov StatusNone => In Progress
        Assigned toNone => valkov

    Back to the top


    Powered by Savane 3.3