helpstoreBackup - Support: sr #108418, linkToDirs not working

 
 

sr #108418: linkToDirs not working

Submitter:  Jonas <sanoj>
Submitted:  Tue 22 Oct 2013 10:54:49 AM UTC
 
Category:  None Priority:  5 - Normal
Severity:  4 - Important Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Operating System:  GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sun 27 Oct 2013 11:35:12 AM UTC, comment #3: 

It works perfectly for me ...
see appended file test.txt (where I added some print statements at the line with your error message)

How do you call linkToDirs.pl exactly?

Do you have permissions to read the lock file? (Error handling from linkToDirs.pl is pretty poor at that point - I will change that.)

(file #29484)

Heinz-Josef Claes <hjclaes>
Project Administrator
Sat 26 Oct 2013 10:45:12 AM UTC, comment #2: 

Yes, it is a zero byte file and the error occurs every time i try to run the script.

doesn't matter, take your time!

Jonas <sanoj>
Tue 22 Oct 2013 05:01:50 PM UTC, comment #1: 

Hi Jonas,

does this file is zero byte file? Is this error reproducible?

Can you send me an email so I can send you a newer version with better error messages? (But this may take some days - I'm travelling and do not have much time at the moment.)

Heinz-Josef Claes <hjclaes>
Project Administrator
Tue 22 Oct 2013 10:54:49 AM UTC, original submission:  

Hi everybody,

i'm using ubuntu 13.10 and the most recent storeBackup release (3.4.2). I backed up my data to one external drive and now want to replicate this backup to another drive. I'm doing this as described in http://www.nongnu.org/storebackup/en/node56.html .

When running linkToDirs (from one external drive to another) the following error is thrown:

Use of uninitialized value $md5 in concatenation (.) or string at /opt/storeBackup/bin/linkToDirs.pl line 623.
ERROR     2013.10.22 12:47:26 20432 cannot copy </media/XXX/partition1/BACKUP/SERIESNAME/2013.10.17_12.26.59/etc/.pwd.lock> to </media/jonas/backup/BACKUP/SERIESNAME/2013.10.17_12.26.59/etc/.pwd.lock>

The file exists but is empty.

Is there any solution for this problem?

Jonas <sanoj>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #29484:  test.txt added by hjclaes (695B - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by hjclaes (Posted a comment)
  • -email is unavailable- added by sanoj (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follows 1 latest change.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-10-27 hjclaes Attached File- Added test.txt, #29484

    Back to the top


    Powered by Savane 3.9