helpSavannah Administration - Support: sr #110456, Registration requirements are...

 
 

sr #110456: Registration requirements are inconsistent and confusing w.r.t. GPL version

Submitted by:  Eli Schwartz <eschwartz>
Submitted on:  Wed 10 Mar 2021 07:07:34 PM UTC  
 
Category:  Savannah website Priority:  5 - Normal
Severity:  3 - Normal Status:  In Progress
Assigned to:  Ineiev <ineiev> Operating System:  None
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 15 Mar 2021 10:42:35 AM UTC, comment #1: 

First, I agree that clarifying license-related hosting requirements wouldn't hurt Savannah.

> > My license is compatible with the GNU GPL or GFDL
>
> This implies a GPL-2.0-only licensed project with many license holders will be acceptable on savannah.nongnu.org


Why do you think it implies GPL-2.0-only?

> > I agree with the hosting requirements
>
> https://savannah.nongnu.org/register/requirements.php
>
> If you follow this link, the last item is licensing, which specifically calls out compatibility with GPL-3.0-or-later.


In fact, we require compatibility with the GPL version 3.0 and any later version; now, one could ask how we can tell if a license like Apache 2.0 is compatible with GPL versions that don't exist yet.  Evidently, we assume that future GPL versions are compatible at least with those permissive licenses that are GPLv3-compatible.

That said, when people submit packages with incompatible licensing, it doesn't take much Savannah admins' time to reject them.

Ineiev <ineiev>
Site AdministratorIn charge of this item.
Wed 10 Mar 2021 07:07:34 PM UTC, original submission:  

https://savannah.nongnu.org/register/

> we only accept free software licenses that are compatible with the GPL


> Checklist
> My license is compatible with the GNU GPL or GFDL


This implies a GPL-2.0-only licensed project with many license holders will be acceptable on savannah.nongnu.org

> I agree with the hosting requirements


https://savannah.nongnu.org/register/requirements.php

If you follow this link, the last item is licensing, which specifically calls out compatibility with GPL-3.0-or-later.

This is unclear, because if you have two different pages that both say a project needs to be GPL-compatible but one of them sticks a 3 on, you're going to have well-meaning people reading the former and skimming over the latter because they think they've already read this section on the previous page.

...

In order to reduce confusion (and possibly make people aware much earlier, if their project is not suitable -- rather than after they fill out the form and get rejected), I would appreciate if the "register new project" page would clarify matters by directly calling out:

> we only accept free software licenses that are compatible with the GPL3


> Checklist
> My license is compatible with the GNU GPL3 or GFDL

Eli Schwartz <eschwartz>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ineiev (Posted a comment)
  • -email is unavailable- added by eschwartz (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-03-15 ineiev StatusNone => In Progress
        Assigned toNone => ineiev

    Back to the top


    Powered by Savane 3.6