bugThe nmh Mail Handling System - Bugs: bug #15216, repl -form argument doesn't allow...

 
 

bug #15216: repl -form argument doesn't allow relative paths

Submitted by:  Peter Maydell <pm215>
Submitted on:  Thu 15 Dec 2005 02:34:16 PM UTC  
 
Category: EnhancementSeverity: 3 - Normal
Priority: 5 - NormalStatus: Wont Fix
Assigned to: NoneOpen/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 21 Mar 2013 01:34:15 AM UTC, comment #3:

Closing per comments.

David Levine <levine>
Project Member
Fri 05 Feb 2010 05:11:32 AM UTC, comment #2:

Just found the following in the mh-profile manpage, note
the last sentence:

$MH
With this environment variable, you can specify a profile other
than .mh_profile to be read by the nmh programs that you invoke.
If the value of $MH is not absolute, (i.e., does not begin with a
"/"), it will be presumed to start from the current working
directory. This is one of the very few exceptions in nmh where
non-absolute pathnames are not considered relative to the user's
nmh directory.

Earl Hood <ehood>
Project Member
Fri 05 Feb 2010 05:01:59 AM UTC, comment #1:

One may consider using the user's mail dir as the base
pathname for resolve relative paths to -form a feature.
Makes it easier to manage multiple formfiles and
of setting a default form in one's .mh_profile.

For testing a formfile, just do:

repl -form `pwd`/foo

Hmmm, looking at code, the file is resolved via etcpath()
function in config/config.c, which documents how
a file is resolved, so the behavior you are seeing
is by design.

Not sure if this is a bug.

Earl Hood <ehood>
Project Member
Thu 15 Dec 2005 02:34:16 PM UTC, original submission:

(debian bug 188750: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=188750)

repl does a chdir before opening the format file, so:
repl -form ./foo
(useful for testing) won't work, because it will try to open <currentmailbox>/./foo rather than ./foo

Peter Maydell <pm215>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by levine (Posted a comment)
  • -unavailable- added by ehood (Posted a comment)
  • -unavailable- added by pm215 (Updated the item)
  •  

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 3 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Thu 21 Mar 2013 01:34:15 AM UTClevineStatusNone=>Wont Fix
      Open/ClosedOpen=>Closed
    Mon 29 Dec 2008 10:42:27 PM UTCpm215CategoryNone=>Enhancement

    Back to the top


    Powered by Savane 3.1-cleanup