bugThe Om Modular Synthesizer - Bugs: bug #19397, om_gtk won't open patches

 
 

bug #19397: om_gtk won't open patches

Submitted by:  None
Submitted on:  Sat 24 Mar 2007 02:48:34 AM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 16 Mar 2008 09:01:53 AM UTC, comment #1:

Same problem here on ubuntu 32bit.
The patch is actually opened in Om (visible in patchage)
But om_gtk do not list it nor show any graphical canvas.

This used to work days ago,but i don't know why it does not anymore on my machine.

BenoƮt Rouits <brouits>
Sat 24 Mar 2007 02:48:34 AM UTC, original submission:

I'm using Gentoo on AMD64 with 2.6.19-ck2-r4 kernel. I'm using the om-0.2.0.tar.gz tarball and I installed all the LADSPA plugins from portage.

Whenever I try to open a patch in om_gtk, nothing happens. It doesn't error or anything, but no patches show up in the gui. Here is the output of om_gtk:

[Main] No engine URL specified. Attempting to use osc.udp://localhost:16180
[OSCController] Started OSC listener on port 10726
[OSCController] Attempting to contact engine at osc.udp://localhost:16180/ . connected
[OSCController] Waiting for response 2: ... received.
[Controller] Registered with engine
Controller] Attempting to contact engine at osc.udp://localhost:16180/ . connected
[OSCController] Waiting for response 2: ... received.
[Controller] Registered with engine[PatchLibrarian] Loading patch /usr/local/share/om/patches/sine.om
[OSCController] Waiting for response 6: . received.

And here is the output of om:

[SlowEventQueue] Starting.
[PostProcessor] Starting.
[AlsaDriver] Successfully opened ALSA sequencer.
[OSC] Started OSC server at osc.udp://antineo-gentoo.glineslan:16180/
[Main] Warning: Failed to lock memory. Timing could suffer.
cannot lock down memory for RT thread (Cannot allocate memory)
[JackDriver] Activated Jack client.
[AlsaDriver] Started realtime MIDI thread (SCHED_FIFO, priority 20)
[OSC] Registered client osc.udp://antineo-gentoo.glineslan:10726/ (1 clients)
[JackDriver] Enabling.

Whenever I try to open the same patch twice, I get this error:

ERROR: Unable to create patch: /sine already exists.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by brouits (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item

    Back to the top


    Powered by Savane 3.1-cleanup