bugAVR Downloader/UploaDEr - Bugs: bug #19882, Many "error in USB...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #19882: Many "error in USB receive" messages received before successful programming.

Submitted by:  David A. Mellis <mellis>
Submitted on:  Wed May 16 15:10:57 2007  
 
Category: NoneSeverity: 3 - Normal
Priority: 5 - NormalItem Group: None
Status: Need InfoPrivacy: Public
Assigned to: NoneOriginator Name: mellis
Open/Closed: OpenRelease: None
Programmer hardware: Device type: 

Fri Aug 26 12:19:25 2011, comment #5:

Is this still an issue at all?

Joerg Wunsch <joerg_wunsch>
Project Administrator
Mon Oct 29 22:54:25 2007, comment #4:

See patch #5655 which apparently addresses the same issue.

Joerg Wunsch <joerg_wunsch>
Project Administrator
Mon Oct 29 21:59:34 2007, comment #3:

I just tried uploading something with an AVRISP mkII, and
cannot see this. Can you verify the problem still exists?

(Quite possible it has been fixed some time ago.)

Joerg Wunsch <joerg_wunsch>
Project Administrator
Wed Jul 25 15:33:15 2007, comment #2:

I have the same problem under Windows with the avrdude and libusb from the latest version of WinAVR (20070525). I get 31 errors:
avrdude.exe: stk500v2_recv_mk2: error in USB receive
and then the flash is written successfully. Has anyone used an AVRISP mkII with avrdude without getting these errors? Can avrdude be patched to return from stk500v2_getsync() for the avrispmkii as well as the jtagice_mkii?

David A. Mellis <mellis>
Thu Jun 14 17:37:41 2007, comment #1:

It seems that my AVRISP mkII is not responding to the sync command (CMD_SIGN_ON aka the byte 1), even with the latest firmware. The sync is retried 33 times, each time with a 10 second timeout, leading to the long delay I noticed.

I noticed the following lines in the stk500v2_getsync() function in stk500v2.c (lines 483-484):

if (pgmtype == PGMTYPE_JTAGICE_MKII)
return 0;

Is that to avoid a similar problem with the JTAGICE mkII? Would it make sense to do the same for the AVRISP mkII, or am I the only one having these problems? If the latter, anyone have any ideas what might be wrong?

David A. Mellis <mellis>
Wed May 16 15:10:57 2007, original submission:

I'm having problems using avrdude with an AVRISPmkII to upload a .hex file to an ATmega168 (on an Arduino board with 16 MHz external oscillator). I'm using the latest versions of libusb and avrdude from CVS on an Intel Mac running Mac OS X 10.4.9 (Tiger). The command line is: avrdude -p m168 -c avrispmkII -P usb -U flash:w:ATmegaBOOT_168.hex

I receive multiple "avrdude: stk500v2_recv_mk2: error in USB receive" messages every 15 seconds or so over the course of a few minutes. Then, the chip is programmed successfully, and at a seemingly "normal" speed.

If I add a -vvvv to my command line, I get the following output:

avrdude: Version 5.3cvs, compiled on May 16 2007 at 09:42:00
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/

System wide configuration file is "/usr/local/etc/avrdude.conf"
User configuration file is "/Users/dmellis/.avrduderc"
User configuration file does not exist or is not a regular file, skipping

Using Port : usb
Using Programmer : avrispmkII
avrdude: usbdev_open(): Found AVRISP mkII, serno: 0000A0019837
avrdude: Sent: . [01]
avrdude: usbdev_recv_frame(): usb_bulk_read(): usb_bulk_read: An error occured during read (see messages above)
avrdude: stk500v2_recv_mk2: error in USB receive
avrdude: Sent: . [01]
avrdude: usbdev_recv_frame(): usb_bulk_read(): usb_bulk_read: An error occured during read (see messages above)
avrdude: stk500v2_recv_mk2: error in USB receive
avrdude: Sent: . [01]
avrdude: usbdev_recv_frame(): usb_bulk_read(): usb_bulk_read: An error occured during read (see messages above)
avrdude: stk500v2_recv_mk2: error in USB receive
avrdude: Sent: . [01]
avrdude: usbdev_recv_frame(): usb_bulk_read(): usb_bulk_read: An error occured during read (see messages above)
avrdude: stk500v2_recv_mk2: error in USB receive
...
avrdude: Sent: . [01]
avrdude: usbdev_recv_frame(): usb_bulk_read(): usb_bulk_read: An error occured during read (see messages above)
avrdude: stk500v2_recv_mk2: error in USB receive
avrdude: stk500v2_getsync(): timeout communicating with programmer

followed by the standard programming output (information about the part, etc). I'm attaching the full output.

Any idea what's wrong? I'm happy to spend some time investigating, but I don't know where to start.

David A. Mellis <mellis>

 

Attached Files
file #12782:  avrdude-trace.txt added by mellis (150kB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by joerg_wunsch (Posted a comment)
  • -unavailable- added by mellis (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon Oct 29 21:59:34 2007joerg_wunschStatusNone=>Need Info
    Wed May 16 15:10:58 2007mellisAttached File-=>Added avrdude-trace.txt, #12782

    Back to the top


    Powered by Savane 3.1-cleanup