bugTechne - Bugs: bug #30408, Package requirements (libpng12)...

 
 

bug #30408: Package requirements (libpng12) were not met

Submitted by:  None
Submitted on:  Sat 10 Jul 2010 06:02:35 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Closed

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 10 Jul 2010 11:51:02 PM UTC, comment #4:

Yeah, that's the package I built. Its dependency packages (including the techne package) needed some tweaking before they'd build. I've removed the package now, and I've pretty happy with foobillard; the only error messages on the console were the one I posted though, and the game window was completely black except for the startup message that said there was no GUI and that everything was controlled through the web interface. That message faded away after about 5 seconds, and the game window remained resolutely black.

Paul Dann <dannpg>
Sat 10 Jul 2010 08:53:33 PM UTC, comment #3:

Start a game from the web interface you say? As far as I recall you don't start a game from the web interface in Billiards although you can restart it from there. How exactly are you trying to run the game?

Try to start a Billiards from the command line and post the messages it prints on the console and the output you see on the screen.

As for FooBillard, you might as well go that route. Depends on what you want really. Billiards has been used for academic research while FooBillard features a nice computer oponent :).

BTW there's a package for Billiards for Arch linux. Have you tried using that?\

http://aur.archlinux.org/packages.php?ID=23333&detail=1

Dimitris Papavasiliou <dpapavas>
Project Administrator
Sat 10 Jul 2010 06:43:55 PM UTC, comment #2:

Thank you for the quick response :)

I'm trying to build Billiards. I installed the libpng12 package from the Arch User's Repository and got Techne compiled. However, it seems something wasn't working with Billiards, because nothing happened when I tried to start a game from the web interface, except for the following console message:

ODE Message 3: LCP internal error, s <= 0 (s=0.0000e+00)

I can't find anything online that might suggest what I'm doing wrong, so unless you happen to have an idea, I'll just give up and give FooBillard a try :)

Paul Dann <dannpg>
Sat 10 Jul 2010 06:25:51 PM UTC, comment #1:

The upcoming release of Techne, version 0.2 actually removes the dependecy on libpng altogether. What are you using Techne for? Billiards or Aviation? If it's Aviation you can try to check out the sources from CVS (and while you're at it maybe check out Airrace as well) and build from there.

The current CVS snapshot of Billiards has a slowdown I haven't found time to investigate yet. Still if you want to try to get it from CVS and give it a try get back to me and I'll look into the issue.

Now the released versions of Billiards and Aviation don't actually use libpng so you can circumvent the problem with the following changes:

1) Remove the following line from configure.ac:
PKG_CHECK_MODULES([LIBPNG], [libpng12])

2) In the file src/Makefile.am remove 'screenshot.so' from the pkglib_PROGRAMS target as well as the lines:

screenshot_so_SOURCES = screenshot.c
screenshot_so_LDFLAGS = -shared -fpic ${AM_LDFLAGS}
screenshot_so_CFLAGS = -fpic ${AM_CFLAGS}

Let me know if you're having trouble following this. I'll send you patches for both files.

Dimitris Papavasiliou <dpapavas>
Project Administrator
Sat 10 Jul 2010 06:02:35 PM UTC, original submission:

It would appear Techne requires libpng 1.2, whereas my system (ArchLinux) has libpng 1.4.3. Any chance of a patch?

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by dannpg (Posted a comment)
  • -unavailable- added by dpapavas (Posted a comment)
  • -unavailable- added by dannpg
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Tue 13 Jul 2010 05:43:43 PM UTCdpapavasOpen/ClosedOpen=>Closed
    Sat 10 Jul 2010 06:07:25 PM UTCdannpgCarbon-Copy-=>Added dannpg

    Back to the top


    Powered by Savane 3.1-cleanup