bugDatabase-driven manual pager suite - Bugs: bug #37663, man gives the error about locale

 
 

bug #37663: man gives the error about locale

Submitted by:  None
Submitted on:  Sat 03 Nov 2012 04:33:22 PM UTC  
 
Category: NoneSeverity: 3 - Normal
Item Group: NoneStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 03 Nov 2012 04:33:22 PM UTC, original submission:

I have

$ locale
LANG=en_GB.UTF-8
LC_CTYPE=ru_RU.UTF-8
LC_NUMERIC=en_GB.UTF-8
LC_TIME=en_GB.UTF-8
LC_COLLATE=ru_RU.UTF-8
LC_MONETARY=ru_RU.UTF-8
LC_MESSAGES=en_GB.UTF-8
LC_PAPER=ru_RU.UTF-8
LC_NAME=ru_RU.UTF-8
LC_ADDRESS=ru_RU.UTF-8
LC_TELEPHONE=ru_RU.UTF-8
LC_MEASUREMENT=ru_RU.UTF-8
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=

$ locale -a
C
en_GB.utf8
POSIX
ru_RU.utf8

But 'man' gives the error:

$ man
man: can't set the locale; make sure $LC_* and $LANG are correct
What manual page do you want?

I set all LC_* to 'en_GB.UTF-8', but the error doesn't disappear. If I set the LC_ALL, the error disappears:

$ LC_ALL=en_GB.UTF-8 man
What manual page do you want?

Does 'man' really need to mandatory LC_ALL set? (If so, this is stupid behavior because many people have different locales in different LC_* variables and they can't use LC_ALL.)

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.

 

Please enter the title of George Orwell's famous dystopian book (it's a date):

 

 

No Changes Have Been Made to This Item

Back to the top


Powered by Savane 3.1-cleanup