newsNews: CVS URL changed

 
 
Latest News
OpenSSH DSA keys Deprecated posted by rwp, Fri 21 Jun 2019 09:34:25 PM UTC - 0 replies
Version Control System Storage Back-End Maintenance Complete posted by rwp, Fri 05 Apr 2019 10:15:05 PM UTC - 0 replies
Version Control System Downtime posted by rwp, Fri 05 Apr 2019 05:52:24 PM UTC - 0 replies
Version Control and Project Download Areas Maintenance Complete posted by rwp, Sat 30 Mar 2019 12:00:42 AM UTC - 0 replies

CVS changes

Item posted by Sylvain Beucler <Beuc> on Tue 13 Dec 2005 10:35:18 PM UTC.

In our effort to better structure the Savannah system and get the necessary fundations for new features, all CVS-related services are moved to cvs.savannah.gnu.org and cvs.savannah.nongnu.org.

You can use 'sv' instead of 'savannah' for short.

 cvs -z3 -d:ext:username@cvs.sv.gnu.org:/sources/project co module_name
 cvs -z3 -d:ext:username@cvs.sv.gnu.org:/web/project co module_name

Anonymous access over SSH, which has been somewhat troublesome, and uses an unnecessary encryption (since it is public access), was disabled. The new structure allowed us to replace it with the more common pserver access. pserver access is anonymous only.

 cvs -z3 -d:pserver:anonymous@cvs.sv.gnu.org:/sources/project co module_name
 cvs -z3 -d:pserver:anonymous@cvs.sv.gnu.org:/web/project co project

We now use 'sources' and 'web' instead of respectively 'cvsroot' and 'webcvs' - this sounds clearer. The old paths are still supported via symbolic links.

Migration: type one of the following one-liner in your CVS working copy:

- For anonymous working copies
find . -path '.*/CVS/Root' -print0 | xargs -0 perl -i -p -e 's/:ext:anoncvs\@(cvs\.)?s/:pserver:anonymous\@cvs.s/'

- For a project member working copy
find . -path '.*/CVS/Root' -print0 | xargs -0 perl -i -p -e 's/\@s/\@cvs.s/'

(Note: this was reported not to work under MSys (see the comments); if you know a more portable way, feel free to reply)

Or, just check out a fresh copy :)

rsync is now enabled on default port (873), you can use it to get your raw CVS files. With this new service, the (resources consuming) daily tarball generation script could be disabled.

rsync cvs.savannah.gnu.org::sources/project/
rsync cvs.savannah.gnu.org::web/project/

ViewCVS was also upgraded. Old URLs are seamlessly redirected to the new ones.

Commit notification was cleaned-up; this doesn't change much, except that those receiving notifications and diffs to the same list as separate mails now get them all in a single mail.

You can ignore the deprecation warnings that CVS issues when sending the e-mail: we need to upgrade our version of log_accum to support new-style CVSROOT/loginfo format, and meanwhile we use the old-style format for that particular hook.

cvs [update aborted]: cannot stat /var/lock/c (posted by Bruce Korb, Fri 16 Dec 2005 12:08:35 AM UTC)

Should this not have all been done before locking out the old access mechanism?  I have a new release already uploaded, but CVS is out of date and I cannot update the web pages either.  Thanks!  Regards, Bruce


Err, well, having some trouble here... (posted by Christian Mauduit, Tue 13 Dec 2005 12:07:38 AM UTC)

Hi,

I'm trying to upload my web pages to Savannah, but I'm having trouble with CVS:

ufoot@guenegaud:~/home/cvs/savannah/t$ cvs -z3 \
-d ufoot@cvs.sv.gnu.org:/web/liquidwar6 co liquidwar6
Enter passphrase for key '/home/ufoot/.ssh/id_ext_dsa':
cvs [checkout aborted]: cannot stat /var/lock/cvs/liquidwar6: No such file or directory

ufoot@guenegaud:~/home/cvs/savannah/t$ cvs -z3 \
-d ufoot@cvs.sv.gnu.org:/sources/liquidwar6 co liquidwar6
Enter passphrase for key '/home/ufoot/.ssh/id_ext_dsa':
cvs [checkout aborted]: cannot stat /var/lock/cvs/liquidwar6: No such file or directory

Some other projects work well with similar commands (more precisely liquidwar and u61, which I opened "a long time ago"). Projects I opened recently seem also wrecked (pygpsweb also has "cannot stat /var/lock/cvs/pygpsweb", and uwikicms has "Cannot access /web/uwikicms/CVSROOT No such file or directory"), but this is not of great concern for now. Since I use GNU Arch 8-)

But the liquidwar6 problem is bothering me, for I need CVS for the web pages.

Thanks in advance,

Christian.


really rocks (posted by paul poulain, Mon 12 Dec 2005 05:24:59 PM UTC)

savannah admins really rocks ;-)
We asked to have only 1 mail for changelog & cvs diff, less than 2 weeks ago, and ... that's done ...

(et ca fait plaisir de trouver des compatriotes)


Setting $CSVROOT to avoid typing 'cvs -d...' (posted by Greg Chicares, Mon 12 Dec 2005 01:39:39 AM UTC)

Is it still possible to set a $CVSROOT shell variable to
avoid typing a long '-d' string in each cvs command? This
works:

  $ cvs -d:ext:chicares@cvs.sv.gnu.org:/sources/lmi add so_attributes.hpp
  cvs add: scheduling file `so_attributes.hpp' for addition
  cvs add: use `cvs commit' to add this file permanently

In the past I had used this in local bash:
  $ export CVSROOT="chicares@subversions.gnu.org:/cvsroot/lmi"
and then could just say 'cvs add [file]'. Of course, that
no longer works, but I tried

  $ export CVSROOT="chicares@cvs.sv.gnu.org:/sources/lmi"
  $ cvs commit -m"Import header with shared-library macros from skeleton branch" so_attributes.hpp

and got:

  CVS moved to cvs.savannah.[non]gnu.org
  Check http://savannah.gnu.org/forum/forum.php?forum_id=4168 for details.
  Anonymous access over SSH is replaced by the (more efficient) pserver.
  cvs [commit aborted]: end of file from server (consult above messages if any)

I get the same message when I issue the same 'commit'
after setting
  $ export CVSROOT=":ext:chicares@cvs.sv.nongnu.org:/sources/lmi"
or
  $ export CVSROOT=":ext:chicares@cvs.sv.gnu.org:/sources/lmi"

Yet this works, even though '-d' matches the last $CVSROOT
definition immediately above:

  $ cvs -d:ext:chicares@cvs.sv.gnu.org:/sources/lmi commit -m"Import header with shared-library macros from skeleton branch" so_attributes.hpp
  /sources/lmi/lmi/so_attributes.hpp,v  <--  so_attributes.hpp
  initial revision: 1.1
  cvs commit: Using deprecated info format strings.  Convert your scripts to use
  the new argument format and remove '1's from your info file format strings.


Thanks! (posted by Han-Wen Nienhuys, Sun 11 Dec 2005 11:34:43 PM UTC)

 

hi,

cvs upping seems to have sped up quite bit. Thanks for this improvement!


www super-membership and webpages (posted by Sylvain Beucler, Sun 11 Dec 2005 10:58:34 PM UTC)

Before anybody ask, I am aware that the www group 'super-membership', that is, their ability to edit any GNU web repository, is not working at the moment.

That's not a common feature, it doesn't fit with the Savane membership scheme, and I need to write a separate script to edit the webgroups (the groups that can access /web/project/).

Webpages will be updated as soon as the sync job at http://www.[nongnu.org] will use the new access method.


deprecated info format strings (posted by Karl Berry, Sun 11 Dec 2005 10:28:33 PM UTC)

I just committed gnueval/evaluations/liquidwar6 with the new scheme, and got this message.  What "info format strings" is it referring to?

Thanks,
Karl

cvs commit: Using deprecated info format strings.  Convert your scripts to use 
the new argument format and remove '1's from your info file format strings. 


rsync (posted by Ales Cepek, Sun 11 Dec 2005 08:12:57 PM UTC)

Can I use rsync to directly update my project source files at savannah?  I would like to purge some useless ATTIC directories created long time ago during reorganization of the project tree.

Ales


RSA Fingerprint (posted by Laurence Finston, Sun 11 Dec 2005 06:41:43 PM UTC)

Hello,

Do you have the RSA fingerprint posted somewhere?

Thanks.

Laurence Finston


Migration one-liners (posted by Sylvain Beucler, Sun 11 Dec 2005 06:36:34 PM UTC)

For anonymous working copies:
find -path '.*/CVS/Root' -print0 | xargs -0 perl -i -p -e 's/:ext:anoncvs\@(cvs\.)?s/:pserver:anonymous\@cvs.s/'

For a project member working copy:
find -path '.*/CVS/Root' -print0 | xargs -0 perl -i -p -e 's/\@s/\@cvs.s/'

Or, just check out a fresh copy :)


it doesn't work! (posted by Apple, Sun 11 Dec 2005 05:25:40 PM UTC)

all it does is just hang
appleboy@dioxide ~/glob2-cvs $ cvs -d:pserver:anonymous@cvs.savannah.gnu.org:/sources/glob2 co glob2

^^command I'm running


    

 

Back to the top


Powered by Savane 3.5