mainSavannah Administration - Support: sr #109703, package savane for debian

 
 

sr #109703: package savane for debian

Submitter:  Svetlana T <svetlana>
Submitted:  Tue 11 Jun 2019 04:40:17 AM UTC
   
 
Category:  None Priority:  5 - Normal
Severity:  3 - Normal Status:  None
Privacy:  Public Assigned to:  None
Operating System:  None Open/Closed:  Open
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Fri 29 Dec 2023 06:49:17 PM UTC, comment #9: 

comment #8:

>
> Especially since (I believe) there is hardly any usage of svn at savannah.


Er.. Savannah administration uses svn for its wiki; a private group uses svn to log the offers of new programs people send to GNU. I believe we certainly want to support svn.

Ineiev <ineiev>
Site Administrator
Fri 29 Dec 2023 05:06:32 PM UTC, comment #8: 

Re viewvc, savannah uses it for svn repo browsing. E.g.:
https://svn.savannah.gnu.org/viewvc/administration/trunk/

Like everything else, it is not fun to make it work with python3, but it is possible. I can send you some build notes if you care.

Certainly easier to stay with older svn and python as long as possible. Especially since (I believe) there is hardly any usage of svn at savannah.

Karl Berry <karl>
Site Administrator
Thu 28 Dec 2023 10:18:09 AM UTC, comment #7: 

Fine. Just forget about what I said. Savane doesn't depend on those. Savannah uses some of them.

Jing Luo <jing>
Group Member
Thu 28 Dec 2023 07:41:26 AM UTC, comment #6: 

comment #5:

> > > Savane also depends on  deprecated software that is no longer available on debian bullseye or bookworm.


(The emphasis is mine.)

> Debian bullseye (-> Trisquel 11) removed all python 2 packages and those who depend on them from the repo. These are the packages that are removed:
> 1. Mailman 2.1 (lists.gnu), Mailman 3 uses python 3 but Savane can't work with Mailman 3 without a lot of changes in both the frontend and the backend, and replacing lists.gnu is in FSF sysadmin's realm


I'm puzzled. TTBOMK, neither frontend nor any backend scripts depend on Mailman. the only Savannah connection to Mailman I can think of is via an unreleased script dwelling in list@lists.gnu.org.

> 2. ViewVC 1.2.y or before, but there is a 1.3.0-dev that uses python 3


Savane doesn't depend on this.

> This doesn't work for me:
> 3. libnss-mysql, it segfaults


It does work at Savannah.

> Partially working or needed patches:
> 4. hgweb's and viewvc's wsgi or fcgi scripts, they depend on python-flup. Only cgi scripts are working


Could you elaborate? why cgi scripts aren't sufficient?

> 5. loggerhead's wsgi script, I had to hardcode the repo's path in the script


I don't understand what you are speaking about here.

> 6. sv_membersh's way to invoke "hg serve --stdio" will be aborted because of a safety check (?). It needs to be invoked by a wrapper script "hg-ssh" that comes with mercurial.


Thank you; let us fix that.

> Probably there's more.


So far I can only see one minor issue with sv_membersh.

Ineiev <ineiev>
Site Administrator
Thu 28 Dec 2023 06:49:50 AM UTC, comment #5: 


comment #4:

> comment #3:
> > Savane also depends on  deprecated software that is no longer available on debian bullseye or bookworm.
>
> Please be more specific. we are definitely much more interested in making Savane work with current software than in running it in abstract simulated environments.



Debian bullseye (-> Trisquel 11) removed all python 2 packages and those who depend on them from the repo. These are the packages that are removed:
1. Mailman 2.1 (lists.gnu), Mailman 3 uses python 3 but Savane can't work with Mailman 3 without a lot of changes in both the frontend and the backend, and replacing lists.gnu is in FSF sysadmin's realm
2. ViewVC 1.2.y or before, but there is a 1.3.0-dev that uses python 3

This doesn't work for me:
3. libnss-mysql, it segfaults

Partially working or needed patches:
4. hgweb's and viewvc's wsgi or fcgi scripts, they depend on python-flup. Only cgi scripts are working
5. loggerhead's wsgi script, I had to hardcode the repo's path in the script
6. sv_membersh's way to invoke "hg serve --stdio" will be aborted because of a safety check (?). It needs to be invoked by a wrapper script "hg-ssh" that comes with mercurial.

Probably there's more.

Jing Luo <jing>
Group Member
Thu 28 Dec 2023 05:44:46 AM UTC, comment #4: 

comment #3:

> Savane also depends on  deprecated software that is no longer available on debian bullseye or bookworm.


Please be more specific. we are definitely much more interested in making Savane work with current software than in running it in abstract simulated environments.

Ineiev <ineiev>
Site Administrator
Thu 28 Dec 2023 01:23:27 AM UTC, comment #3: 

Is this being worked on? I'm interested in making a generic qemu image though. A deb package would only get the php and perl scripts installed, and a lot of things may not work. Savane also depends on  deprecated software that is no longer available on debian bullseye or bookworm.

Jing Luo <jing>
Group Member
Thu 17 Aug 2023 05:41:00 PM UTC, comment #2: 

See also task #15442.

Ineiev <ineiev>
Site Administrator
Tue 11 Jun 2019 07:01:26 AM UTC, comment #1: 

What is missing in order to have it?

Ineiev <ineiev>
Site Administrator
Tue 11 Jun 2019 04:40:17 AM UTC, original submission:  

I would like to suggest to have a savane package for debian (or trisquel, etc)

Svetlana T <svetlana>
Site Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by karl (Posted a comment)
  • -email is unavailable- added by jing (Posted a comment)
  • -email is unavailable- added by ineiev (Posted a comment)
  • -email is unavailable- added by svetlana (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

    No changes have been made to this item

    Back to the top

    Powered by Savane 3.13-ee12.
    Corresponding source code