taskmldonkey, a multi-networks file-sharing client - Tasks: task #4393, BT: support min-interval key from...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

task #4393: BT: support min-interval key from trackers

Submitted by:  Laurento Frittella <mrfree>
Submitted on:  Fri 08 Jul 2005 09:35:09 AM UTC
 
Category:  Bittorrent-Plugin Priority:  * 5 - Normal
Status:  Done Assigned to:  None
Open/Closed:  Closed Should Start On:  Fri 08 Jul 2005 12:00:00 AM UTC
Should be Finished on:  Fri 08 Jul 2005 12:00:00 AM UTC
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

( Jump to the original submission )

Sun 14 Aug 2005 11:05:37 PM UTC, comment #6: 

Patch fixing this applied to 2.6.1

spiralvoice <spiralvoice>
Project Administrator
Fri 08 Jul 2005 09:35:09 AM UTC, comment #5: 

This item has been reassigned from the project mldonkey, a multi-networks file-sharing client bugs tracker to your tracker.

The original report is still available at bugs #13080

Following are the information included in the original report:

[field #0]                  Item ID: 13080
[field #1]                 Group ID: 1409
[field #2]              Open/Closed: Open
[field #3]                 Severity: 3 - Normal
[field #4]                  Privacy: Public
[field #5]                 Category: Bittorrent-Plugin
[field #6]             Submitted by: mrfree
[field #7]              Assigned to: None
[field #8]             Submitted on: Fre 13.05.2005 um 21:54
[field #9]                  Summary: support min-interval key from trackers
[field #10]      Original Submission: I m trying to download a torrent file using mldonkey, but in log mlnet reports...

Failure from BT-Tracker http://madmaster.hopto.org/trader/.php in file: Reason: Your client is out of date - Plz upgrade
BT: received unknown entry in answer from tracker: "min interval"
BT-Tracker return: stopped
[field #12]               Item Group: Feature request
[field #13]                   Status: Need Info
[field #14]        Component Version: None
[field #15]         Platform Version: Linux
[field #16]          Reproducibility: None
[field #17]               Size (loc): None
[field #18]            Fixed Release: None
[field #19]          Planned Release: None
[field #20]                   Effort: 0.00
[field #24]                 Priority: 5 - Normal
[field #27]         Percent Complete: 0%
[field #29]                  Release: 2.5.30.15
[field #54]          Binaries Origin: CVS / Self compiled
[field #55]                 CPU type: Intel x86
[field #56]                      CPU: None
[field #57]     Custom Select Box #4: None
[field #58]     Custom Select Box #5: None
[field #59]     Custom Select Box #6: None
[field #60]     Custom Select Box #7: None
[field #61]     Custom Select Box #8: None
[field #62]     Custom Select Box #9: None
[field #63]    Custom Select Box #10: None

spiralvoice <spiralvoice>
Project Administrator
Sat 14 May 2005 05:31:31 PM UTC, comment #4: 

It could be the min interval thing. If that's the case, you can work around that by setting the option min_tracker_reask_interval to the desired value, until it is supported.

mrfree: To be sure that (mldonkey doesn't support the min interval yet) is realy what is meant with that message, you could ask the admins of that tracker.

Amorphous <amorphous>
Sat 14 May 2005 04:36:11 PM UTC, comment #3: 

I tell that mldonkey bt plugin is out of date because the tracker reports this:

Failure from BT-Tracker http://madmaster.hopto.org/trader/<etc_etc>.php in file: <filename> Reason: Your client is out of date - Plz upgrade

Isn't a my personal opinion :)

Laurento Frittella <mrfree>
Sat 14 May 2005 02:11:04 PM UTC, comment #2: 

Extracts from http://wiki.theory.org/BitTorrentSpecification

Tracker HTTP/HTTPS Protocol
...
The tracker responds with "text/plain" document consisting of a bencoded dictionary with the following keys:
...
min interval: Minimum announce interval. If present clients must not reannounce more frequently than this.

Anonymous
Sat 14 May 2005 12:34:57 PM UTC, comment #1: 

could you tell me why it should be out of date? i couldn't find anything at that url.
what protocoll (change/addition) does it need to support?

Amorphous <amorphous>
Fri 08 Jul 2005 09:35:09 AM UTC, original submission:  

I'm trying to download a torrent file using mldonkey, but in log mlnet reports...

Failure from BT-Tracker http://madmaster.hopto.org/trader/<etc_etc>.php in file: <filename> Reason: Your client is out of date - Plz upgrade
BT: received unknown entry in answer from tracker: "min interval"
BT-Tracker return: stopped <filename>

Laurento Frittella <mrfree>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

Only logged-in users can vote.

 

 

 

 

Follow 7 latest changes.

Date Changed by Updated Field Previous Value => Replaced by
2005-08-14 spiralvoice StatusReady For Test => Done
    Open/ClosedOpen => Closed
2005-08-05 beedauchon StatusIn Progress => Ready For Test
2005-07-17 beedauchon StatusNone => In Progress
2005-07-08 spiralvoice CategoryNone => Bittorrent-Plugin
2005-07-08 spiralvoice SummaryReassigned item: support min-interval key from trackers => BT: support min-interval key from trackers
2005-07-08 spiralvoice Reassign itemFrom group mldonkey, a multi-networks file-sharing client, bugs tracker => To group mldonkey, a multi-networks file-sharing client, task tracker

Back to the top


Powered by Savane 3.9