bugstoreBackup - Bugs: bug #53203, Missleading error message from...

 
 

bug #53203: Missleading error message from linkToDirs.pl if targetDir does not existe

Submitter:  None
Submitted:  Thu 22 Feb 2018 08:44:36 AM UTC
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Thu 22 Feb 2018 08:44:36 AM UTC, original submission:  

I used linkToDirs.pl with --targetDir pointing to a non-existing folder. Therefore I get an error message as follows:

VERSION   2018.02.22 09:38:22 32329 linkToDirs.pl, 3.5
Use of uninitialized value $devT in string ne at /usr/lib/storeBackup/bin/linkToDirs.pl line 394.
ERROR     2018.02.22 09:38:22 32329 directory </backup/storeBackup/testseries/2017.11.18_14.35.01> is not on the same device as </backup/replica/testseries> - setting hard links is not possible

The error complains about "not the same device" while the real error is the non-existing target dir.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

Only logged-in users can vote.

 

 

 

 

No changes have been made to this item

Back to the top


Powered by Savane 3.9