bugConcurrent Versions System - Bugs: bug #55674, "init" command missing...

 
 

bug #55674: "init" command missing from manpage

Submitted by:  None
Submitted on:  Fri 08 Feb 2019 11:29:34 AM UTC
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Release: 
Fixed Release:  None Fixed Feature Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Fri 08 Feb 2019 11:29:34 AM UTC, original submission:  

I was surprised by

$ cd /tmp
$ mkdir foo
$ cvs -d /tmp/foo init
cvs [init aborted]: init to an existing repository is restricted to members of the group cvsadmin
$ grep cvsadmin /etc/group
$

The only mention of the cvsadmin group in the manpage is that the "admin" command is restricted to members of that group if the group exists. I was stuck until a kind soul explained that I should not have created the empty directory first, as even though there was no CVSROOT within it, it still counted as a "repository". A short description of the "init" command in the manpage explaining that it creates the directory itself would have been useful.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

CC list is empty

 

There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

Only logged-in users can vote.

 

 

 

 

No changes have been made to this item

Back to the top


Powered by Savane 3.9