bugpktools - Bugs: bug #56611, pktools.pc includes -llasClasses...

 
 

bug #56611: pktools.pc includes -llasClasses unconditionally (wrong when liblas support not enabled)

Submitted by:  Bas Couwenberg <sebastic>
Submitted on:  Thu 11 Jul 2019 01:31:21 PM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu 11 Jul 2019 01:31:21 PM UTC, original submission:  

When not building with libLAS support the pkg-config file (pktools.pc) includes `-llasClasses` whereas the library is not built.

With libLAS being deprecated upstream in favor of PDAL, the libLAS support should be replaced with PDAL.

The liblas package will be removed from Debian in the next release (bullseye) due to the outstanding security issues that don't get resolved due it being deprecated upstream.

Bas Couwenberg <sebastic>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by sebastic (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.6