bugdavfs2 - Bugs: bug #60994, DNS TTL seems not to be respected

 
 

bug #60994: DNS TTL seems not to be respected

Submitted by:  None
Submitted on:  Sat 31 Jul 2021 10:34:24 AM UTC  
 
Category:  None Severity:  3 - Normal
Item Group:  None Status:  Invalid
Privacy:  Public Assigned to:  Werner Baumann <wbaumann>
Open/Closed:  Open

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 07 Aug 2021 04:04:01 PM UTC, comment #1: 

The TTL of DNS-records is for internal use of the Daomain Name System. It makes sure that DNS-caches never serve outdated information.

Usually the IP-address of a server will stay unchanged much, much longer than the TTL. An application that uses system services to get the IP-address for some DNS-name will usually not get any information about TTL. It will use the address it gets and use it until the application or the server closes the connection or the connection breaks down for some other reason.

The problem is the dynamic address of your server. You cant have a long lasting connection with a moving target.

By the way:
It is a voluntary decision of ISPs to frequently change the IP-addresses of their customers. This will make internet users depend of the services of big companies and helps to disable a real peer-to-peer-net, which in turn helps making money and controlling the internet.

Werner

Werner Baumann <wbaumann>
Project AdministratorIn charge of this item.
Sat 31 Jul 2021 10:34:24 AM UTC, original submission:  

I use davfs2 to mount a webdav endpoint that uses DynDNS, which means, that the IP of said endpoint will regularly change and the Domain I use to access it, will change accordingly.

However, davfs2 does not seem to recognize the changed DNS entry, probably because it either caches the IP address or uses a library that doesn't respect the DNS TTL.

This results in the requirement to remount the webdav resource every time it's IP address has changed.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by wbaumann (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-08-07 wbaumann StatusNone => Invalid
        Assigned toNone => wbaumann

    Back to the top


    Powered by Savane 3.7