bugLinterna Mágica - Bugs: bug #37357, Youtube doesn't work because of...

 
 

bug #37357: Youtube doesn't work because of signatures

Submitted by:  None
Submitted on:  Sat Sep 15 14:45:17 2012  
 
Category: Previously working website does not anymoreSeverity: 3 - Normal
Item Group: NoneStatus: Fixed
Privacy: PublicAssigned to: Ivaylo Valkov <valkov>
Open/Closed: ClosedRelease: 0.0.12

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Thu Nov 15 05:43:46 2012, comment #5:

Hi,

Since the reported link is working and there are no comments since my last request I am planning to close this bug report. As of 24th of November if there is no new information in relation to this bug report it will be considered fixed.

If the problem is still present after the bug report is closed, please feel free to reopen it.

Thank you.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Sat Nov 3 15:03:48 2012, comment #4:

Hi,

As there is now fix for bug #36888, could you report if there are still issues with some YouTube videos related to this fix?

I'm able to play the URL in the last comment with Totem plugin in Trisquel 5.5.

Thanks.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Tue Sep 18 23:32:16 2012, comment #3:

Hi, just tested with rev314 on Firefox 15.0, Fedora 17. Wprk for some videos and not for others. For example,

http://www.youtube.com/watch?v=vIwhnJ5K810

This works in totem-vegas but not on LM with the totem plugin, see only black screen while audio plays in the background.Don't know whether it might have something to do with bug 36888

P.S. I am the same guy who filed bug 36888 (but not the person who filed this one)

Thanks.

Anonymous
Tue Sep 18 07:37:54 2012, comment #2:

It is fixed in trunk and the stable branch (0.0.12). The svn builds are updated. The stable one is with version 0.0.12-2, for which I will release a tarball tonight or tomorrow.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Sun Sep 16 14:49:13 2012, comment #1:

Hi,

Thanks for reporting and proposing a work-around. I was unavailable due to very personal reasons and could not be part of the discussion at the Trisquel's mailing list and take some action.

I'll try to fix the bug and release a bug-fix release as soon as possible.

Ivaylo Valkov <valkov>
Project AdministratorIn charge of this item.
Sat Sep 15 14:45:17 2012, original submission:

Hi!

I don't use Linterna, but people on the Trisquel's English forum are reporting that Youtube video's aren't playing. This is most probably because now every video URL requires a signature to be appended to it.

I write my own Youtube video downloader and wasn't working as of today. I use the variable "url_encoded_fmt_stream_map" to generate HTML anchors to the video files. There's new variable called "sig" in url_encoded_fmt_stream_map. I now append "&signature=" + the value of sig to every video's URL and it works.

I hope I was useful!

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by valkov (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun Dec 2 13:42:07 2012valkovStatusReady For Test=>Fixed
      Open/ClosedOpen=>Closed
    Tue Sep 18 07:37:54 2012valkovStatusConfirmed=>Ready For Test
    Sun Sep 16 14:49:13 2012valkovStatusNone=>Confirmed
      Assigned toNone=>valkov

    Back to the top


    Powered by Savane 3.1-cleanup1