newsSavannah Administration - News: Secure FTP access to download area

 
 
Latest News
frontend upgraded posted by ineiev, Wed 31 Jan 2024 05:45:55 PM UTC
[download] SFTP disabled posted by ineiev, Mon 27 Nov 2023 11:00:33 AM UTC
git post-receive UDP syndication posted by carlc, Thu 31 Aug 2023 11:57:10 PM UTC
re-enabling reminders posted by ineiev, Tue 02 May 2023 11:40:13 AM UTC
frontend upgraded posted by ineiev, Fri 13 May 2022 06:43:50 AM UTC

Secure FTP access to download area

Item posted by Loïc Dachary <loic> on Fri 12 Jul 2002 05:08:59 PM UTC.

Secure FTP access to download area Many people complained that rsync over ssh were too difficult to deal
with and that scp alone did not have enough functionalities to
properly manage the upload area of Savannah projects. Savannah now
offers the sftp service which is an equivalent of ftp running over an
ssh connection. It should be included in popular ssh distributions. If
it is not the case, we suggest you consider an upgrade.

A typical usage for project MYPROJECT would be:

sftp MYUSERNAME@freesoftware.fsf.org:/MYPROJECT/
Connecting to freesoftware.fsf.org...
Changing to: /uri/

From this point you can PUT files in the upload area and immediately
see them at http://savannah.gnu.org/download/MYPROJECT/. You can also
delete existing files (RM), create directories (MKDIR) or change the
file permissions (CHMOD).

It is our hope that sftp will make your life easier.

Happy hacking, the Savannah Hackers



problems : (posted by James Michael DuPont, Sun 01 Jun 2003 07:51:13 AM UTC)

try 1 :
sftp  mdupont@freesoftware.fsf.org:/intrspctr/
Connecting to freesoftware.fsf.org...
Connection closed

rsync -av  --rsh=ssh ./redland-dist.tgz mdupont@freesoftware.fsf.org:/upload/
Sorry, you are only allowed to execute :
   - CVS_RSH=ssh cvs commands
   - rsync from /cvsroot or /upload.
   - rsync to /upload.
   - sftp to and from /upload.
rsync: connection unexpectedly closed (0 bytes read so far)
rsync error: error in rsync protocol data stream (code 12) at io.c(165)

any ideas?


Finally figured out how to make this work! (posted by Dan Nelson, Fri 27 Dec 2002 10:16:05 PM UTC)

Apparently the sftp-server component is in the wrong place on freesoftware.fsf.org.  You need to add the -s flag to force the path that it expects:

sftp -1 -s /usr/lib/sftp-server MYUSERNAME@freesoftware.fsf.org:/MYPROJECT/

This definitely does work; I've tried from a couple different OSes.


the command above is wrong (posted by Daniel Baumann, Sat 27 Jul 2002 05:25:16 PM UTC)

the correct command is:

sftp -1 MYUSERNAME@freesoftware.fsf.org:/MYPROJECT/


Authentication (posted by Luca Saiu, Sat 27 Jul 2002 03:39:14 PM UTC)

  Sorry, when I tried the new SFTP access for upgrading the download area of my project, epsilon I was asked for a password.
  My login password for Savannah did not work.

  I tried:
sftp positrone@freesoftware.fsf.org:/epsilon/

  Have you an hint?

  Thanks

-- positrone


    

 

Back to the top

Powered by Savane 3.13-c373.
Corresponding source code