newsgravaty - News

 
 

2014-04-18 gravaty 3.0.5 (Ruby 2.0) and 4.0.0 (Ruby 2.1.1) released

Item posted by Marco Bresciani <marcobresciani> on Fri 18 Apr 2014 02:10:49 PM UTC.

Please note that due to semver.org rules, former 2.x line with Ruby 2.0 has now became 3.x while former 3.x line with Ruby 2.1.1 has now became 4.x.
  When available, former 4.x line with Ruby 2.2 will become 5.x.

= Version 4.0.0
  * +1.0.0 Updated to 3.0.5.
  * IN PROGRESS: improvements on RDoc contents and layout.
  * PENDING IMPORTANT BUG: https://savannah.nongnu.org/bugs/?39928

= Version 3.0.5
  * NOTES: Release line 5.x will be based on Ruby 2.2.
  * NOTES: Release line 4.x is based on Ruby 2.1.1
  * +0.0.1 Changing assert_raise block with .must_raise method (whether possible).
  * +0.0.1 Simplyfing test_pixelsize.rb.
  * +0.0.1 Adding specific tests for error raisers.
  * +0.0.1 Utils module split into Raisers and RpcConnector.
  * +0.0.1 gems minimum versions update in gemspec.
  * +1.0.0 Removing the readability of the parser and rpc_connector attributes of Gravaty objects.
  * IN PROGRESS: Preparing 2.9.x with an attempt at adding XML-RPC API (see http://en.gravatar.com/site/implement/xmlrpc).
  * KNOWN BUG: https://savannah.nongnu.org/bugs/?39928

Back to the top

Powered by Savane 3.13-4b48.
Corresponding source code