mainSavannah Administration - Support: sr #111062, Can log into savannah.nongnu.org...

 
 

sr #111062: Can log into savannah.nongnu.org but not savannah.gnu.org

Submitter:  James Youngman <jay>
Submitted:  Tue 07 May 2024 09:18:59 PM UTC
   
 
Category:  Savannah website Priority:  5 - Normal
Severity:  3 - Normal Status:  Done
Privacy:  Public Assigned to:  ineiev
Operating System:  GNU/Linux Open/Closed:  Closed
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

  Spam posted by _359056
  Spam posted by anonymous
Sat 11 May 2024 04:06:41 PM UTC, comment #8: 

Thank you, now I can reproduce this.

comment #6:

> session_hash=(something else) (domain=.savannah.gnu.org)

...

> session_uid=(the same value) (domain=.savannah.gnu.org)


It turns out that these stale cookies override the new ones; I've added some code to remove them.

Let us see if other people are affected by other bugs.

Ineiev <ineiev>
Site Administrator
Sat 11 May 2024 11:39:54 AM UTC, comment #7: 

Deleting the cookies associated with .savannah.gnu.org without deleting the cookies associated with savannah.gnu.org and re-loading the page shows that the website now believes I'm logged in.

James Youngman <jay>
Sat 11 May 2024 11:02:12 AM UTC, comment #6: 

My cookies:

savannah.nongnu.org

SV_THEME=Savannah
redirect_to_https=1
session_hash=(something)
session_uid=(something)

All cookies are HttpOnly.   Session_hash and session_uid are marked “secure”.  All are in domain “savannah.nongnu.org”.


savannah.gnu.org

No SV_THEME cookie.
redirect_to_https=1 |(domain=savannah.gnu.org)
session_hash=(something)  (domain=savannah.gnu.org)
session_hash=(something else) (domain=.savannah.gnu.org)
session_uid=(something) (somain=savannah.gnu.org)
session_uid=(the same value) (domain=.savannah.gnu.org)

All cookies are HttpOnly.   Session_hash and session_uid are marked “secure”. Not all in the same domain.



James Youngman <jay>
Sat 11 May 2024 04:43:53 AM UTC, comment #5: 

Thank you, this is helpful.

Can you list your cookies for savannah.gnu.org and savannah.nongnu.org (without their values)?

Ineiev <ineiev>
Site Administrator
Sat 11 May 2024 03:39:50 AM UTC, comment #4: 

Meanwhile I can't login to sv.gnu.org....

Jing Luo <jing>
Group Member
Sat 11 May 2024 12:49:30 AM UTC, comment #3: 

I am reproducing this problem right now.  I cannot log into the nongnu side of things.  I had to use a different system in order to post this comment.

I log into the gnu.org site with the checkbox to log into the nongnu site too.  Not logged into nongnu.

I try to login into nongnu.  Click on Login.  The page operates normally but then the left navigation area shows a Login control and I am not logged in.

Bob Proulx <rwp>
Site Administrator
Fri 10 May 2024 05:17:40 PM UTC, comment #2: 

I can't reproduce this.  I did push a cookie-related commit, but I don't think it fixed the bug.  If the problem persists for you, could you list your cookies for savannah.gnu.org and savannah.nongnu.org (without their values)?

Ineiev <ineiev>
Site Administrator
Thu 09 May 2024 07:47:20 AM UTC, comment #1: 

Clarification:  I wrote:

>  With no indication my login has been unsuccessful.  


What I meant by that was that there was no error message.   But the navigation menu on the left side still says "Not Logged In" while for a successful login I would expect "Logged in as jay".

James Youngman <jay>
Tue 07 May 2024 09:18:59 PM UTC, original submission:  

If I visit https://savannah.gnu.org/account/login.php?uri=%2Fbugs%2F%3F63488 and check the "Login also in savannah.nongnu.org" checkbox and then log in using my username (jay) and password, then I end up logged in only to savannah.nongnu.org but not to savannah.gnu.org.

After log-in, the page I end up on is the same one I began at (in my case a page detailing a bug I want to update).  With no indication my login has been unsuccessful.  

It was only when I visited https://savannah.nongnu.org/support/?group=administration&func=additem that I saw that I was in fact logged into savannah.nongnu.org.

I checked the FAQ without seeing anything that appeared to be related.  This problem appears to be reproducible for me at least.   In case you need to check the logs, the last time I attempted to log in was approximately Tue 07 May 2024 17:12:24 EDT (EDT meaning East coast US time).

James Youngman <jay>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by _359056 (Posted a comment)
  • -email is unavailable- added by jing (Posted a comment)
  • -email is unavailable- added by rwp (Posted a comment)
  • -email is unavailable- added by ineiev (Updated the item)
  • -email is unavailable- added by jay (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2024-06-14 ineiev StatusReady For Test Done
        Open/ClosedOpen Closed
    2024-05-11 ineiev StatusIn Progress Ready For Test
    2024-05-08 ineiev StatusNone In Progress
        Assigned toNone ineiev

    Back to the top

    Powered by Savane 3.13-0ba7.
    Corresponding source code